Download it now!
Bug 50540 - View area jumps when start drawing
Summary: View area jumps when start drawing
Status: RESOLVED DUPLICATE of bug 50386
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Muhammad Haggag
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-05-31 07:25 UTC by Ivan Timofeev (retired)
Modified: 2012-06-04 11:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Timofeev (retired) 2012-05-31 07:25:33 UTC
Since the "word count in status bar" feature was implemented (see Bug 34772):

1. Open new Writer document.
2. Scroll down, the cursor should become invisible.
3. Start to draw a line, don't release the mouse button quickly.

Unexpected behavior: Writer brings the view back to the cursor.

Similar to Bug 50386.
Comment 1 Muhammad Haggag 2012-06-02 09:22:43 UTC
I confirmed that this is caused by the word counting logic focusing the view on the cursor. Will be fixed alongside 50386.
Comment 2 Muhammad Haggag 2012-06-04 11:40:59 UTC
Patch was added to 50386, and I verified it fixes this as well. Let's follow up there.

*** This bug has been marked as a duplicate of bug 50386 ***