Download it now!
Bug 50585 - FILESAVE: Save in format 'docbook' does not work
Summary: FILESAVE: Save in format 'docbook' does not work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Docbook
  Show dependency treegraph
 
Reported: 2012-06-01 06:32 UTC by tbb
Modified: 2020-09-16 14:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Documents to reproduce the issue (11.30 KB, application/x-zip)
2013-02-26 15:33 UTC, Muhammad Haggag
Details
OOo 3.4 docbook version of the Muhammad Haggag example (1.19 KB, application/docbook+xml)
2013-03-13 23:43 UTC, tbb
Details
Selecting exort type (82.63 KB, image/png)
2020-09-16 10:29 UTC, tbb
Details
Dialog after pressing the save button (37.28 KB, image/png)
2020-09-16 10:29 UTC, tbb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tbb 2012-06-01 06:32:05 UTC
The result is a document, that contains only the heading lines. The difference between the OO-XSLT and the LO-XSLT is minimal so I think, that LO uses a different XSLT engine.
Comment 1 ydutrieux 2012-12-17 08:09:13 UTC
Hi tbb,

could you please join a odt document + his result document (and eventually, the document that should be procuced) to see if we can reproduce with our platform.

Regards
Comment 2 Muhammad Haggag 2013-02-26 15:33:43 UTC
Created attachment 75578 [details]
Documents to reproduce the issue

I can confirm the issue on LO Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) on Windows x64. Attached is a short ODT accompanied with the XML produced by LO when saved as docbook. It lost most of the document.
Comment 3 Bjoern Voigt 2013-03-12 08:55:08 UTC
I can confirm this too for LibreOffice 4.0.1.2 (x86_64, Linux RPMS www.libreoffice.org). In my experience only very small and simple documents can be saved as Docbook.
Comment 4 tbb 2013-03-13 23:43:02 UTC
Created attachment 76503 [details]
OOo 3.4 docbook version of the Muhammad Haggag example

The OOo 3.4 (same as with OOo 3.2) export to docbook of the Muhammad Haggag example. The difference is obviosly, and this example is without pictures, frames ...
Comment 5 QA Administrators 2015-04-19 03:19:45 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-06-15 06:06:22 UTC
(In reply to Muhammad Haggag from comment #2)
> Created attachment 75578 [details]
> Documents to reproduce the issue
> 
> I can confirm the issue on LO Version 4.0.0.3 (Build ID:
> 7545bee9c2a0782548772a21bc84a9dcc583b89) on Windows x64. Attached is a short
> ODT accompanied with the XML produced by LO when saved as docbook. It lost
> most of the document.

Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 7 QA Administrators 2016-09-20 10:25:31 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2020-09-16 04:05:21 UTC Comment hidden (obsolete)
Comment 9 tbb 2020-09-16 07:00:49 UTC
Dear QA Team,

a retest is not possible because the selection of the save format "Docbook (.XML)" results in a "Word 2003 XML" format. Short the Docbook support is completely off.

Bye Thomas

LO 6.4.4.2 (Linux)
Comment 10 Buovjaga 2020-09-16 07:12:51 UTC
(In reply to tbb from comment #9)
> Dear QA Team,
> 
> a retest is not possible because the selection of the save format "Docbook
> (.XML)" results in a "Word 2003 XML" format. Short the Docbook support is
> completely off.

What do you mean? It seems to work for me:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
<article lang="">
  <para>dsff</para>
</article>

Tested with
Arch Linux 64-bit
Version: 7.0.1.2
Build ID: 00(Build:2)
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); Käyttöliittymä: fi-FI
=7.0.1-1
Calc: threaded
Comment 11 tbb 2020-09-16 08:18:34 UTC
Please have a look at my LO version. I always test against the current production release. Possibly fixed in 7.X.X

Bye Thomas
Comment 12 Buovjaga 2020-09-16 09:57:39 UTC
(In reply to tbb from comment #11)
> Please have a look at my LO version. I always test against the current
> production release. Possibly fixed in 7.X.X

Please test with an appimage, it is super easy: https://libreoffice.soluzioniopen.com/
Comment 13 tbb 2020-09-16 10:29:07 UTC
Created attachment 165566 [details]
Selecting exort type
Comment 14 tbb 2020-09-16 10:29:49 UTC
Created attachment 165567 [details]
Dialog after pressing the save button
Comment 15 tbb 2020-09-16 10:30:58 UTC
Nope, no difference. LO selects always "Word 2003 XML". The result file is in the Microsoft format (pure XML).

I try the JDK 11 (Debian version) and  JDK 8 (Azul version)

Bye Thomas

Version: 7.0.1.1
Build ID: <buildversion>
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kf5
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded
Comment 16 Buovjaga 2020-09-16 11:40:27 UTC
(In reply to tbb from comment #15)
> Nope, no difference. LO selects always "Word 2003 XML". The result file is
> in the Microsoft format (pure XML).
> 
> I try the JDK 11 (Debian version) and  JDK 8 (Azul version)
> 
> Bye Thomas
> 
> Version: 7.0.1.1
> Build ID: <buildversion>
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kf5
> Locale: de-DE (de_DE.UTF-8); UI: de-DE
> Calc: threaded

That is very weird. I am using Linux and kf5 as well, but for me it works fine.

What is even better is that DocbookBorked.odt now exports fine to DocBook! It does not lose anything.

The full result:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
<article lang="">
  <para>Docbook: Borked?</para>
  <para>Most indeedly<footnote><para>Yep, that's not a word.</para></footnote>, good sire</para>
  <sect1>
    <title>A Heading</title>
    <para>This is a normal paragraph under a heading 1.</para>
    <sect2>
      <title>A 2nd-level Heading</title>
      <para>This is a normal paragraph under a heading 2.</para>
      <orderedlist>
        <listitem>
          <para>Bullet lists?</para>
        </listitem>
        <listitem>
          <para>Bullet lists!</para>
        </listitem>
      </orderedlist>
    </sect2>
    <sect2>
      <title>Another 2nd-level Heading</title>
      <para>This is yet another normal paragraph under a heading 3.</para>
      <orderedlist>
        <listitem>
          <para>Numbered lists?</para>
        </listitem>
        <listitem>
          <para>NUMBERED LISTS! WOO!</para>
        </listitem>
      </orderedlist>
    </sect2>
  </sect1>
</article>
Comment 17 tbb 2020-09-16 14:01:25 UTC
That looks great! I think this issue is resolved. If my export type selection problem will be in the next production release, I will open a new entry. Thanks for your help!

Bye Thomas