Bug 50590 - : Character account in Tools is not correct!!
Summary: : Character account in Tools is not correct!!
Status: RESOLVED DUPLICATE of bug 46757
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-01 08:08 UTC by Seda Stamboltsyan
Modified: 2012-06-28 01:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The Character count window with wrong numbers. (44.51 KB, image/gif)
2012-06-01 08:08 UTC, Seda Stamboltsyan
Details
docx file with track changes-wrong character numbers (18.78 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-06-03 06:59 UTC, Seda Stamboltsyan
Details
odt file without track changes-wrong character numbers (31.59 KB, application/vnd.oasis.opendocument.text)
2012-06-03 06:59 UTC, Seda Stamboltsyan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Seda Stamboltsyan 2012-06-01 08:08:52 UTC
Created attachment 62379 [details]
The Character count window with wrong numbers.

Problem description: In Writer, Tools, Word Count- the number of characters both with and without spaces is INCORRECT. I compared the numbers in different other programs. Even there is such a problem that the number of characters without spaces is bigger than the one with spaces. For the latter problem see the attachment.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Korrawit Pruegsanusak 2012-06-03 02:33:19 UTC
Thanks for the bug report. But could you please answer:

1. what's your language in the document

2. can you attach the document here, note that it'll be publicly available
   if not, can you try to create dummy document in same language and try again

3. what's the result that you expected, in other words, what's the result from other programs, and which program
Comment 2 Seda Stamboltsyan 2012-06-03 06:59:01 UTC
Created attachment 62449 [details]
docx file with track changes-wrong character numbers
Comment 3 Seda Stamboltsyan 2012-06-03 06:59:51 UTC
Created attachment 62450 [details]
odt file without track changes-wrong character numbers
Comment 4 Seda Stamboltsyan 2012-06-03 07:01:15 UTC
1. The language is Armenian.

2. I'm attaching a document in two versions but with the same text. Just now I noticed that this problem occurs when the file is full of track change records. All my other files with track changes show incorrect numbers too, while those without this record show more or less correct numbers, compared with Microsoft Word and internet various character count services, for example, Zoho document's or of this one - http://www.webworldindex.com/countcharacters.htm).

When I copy the same file's text into a new window in LibreOffice Writer and track changes record is deleted or I select the text in the same document with ctrl A, the character numbers shown are different.

However, those same files with track changes when opened with Microsoft Word (in which case the record of track changes is kept) show correct numbers.

3. The difference can be like this:
(on the example of a large file)
 
118306 (with spaces),  105595 (no spaces) - in LibreOffice (the document is with track changes record but the characters are counted with the option of the final version of the text in which the track changes are not shown)

104697 (with spaces), 93285 (no spaces) - in LibreOffice (the same text is copied an a new window or is counted in the same file with track changes but selecting the whole text with ctr A)

106181 (with spaces), 93285 (no spaces) - in Microsoft Word v.10 (the same document with the same track changes record)
106200 (with spaces), 93285 (no spaces) - in Microsoft Word v.10 (the same text copied in a new MS Word document, without track changes record)


106816 (with spaces)- the same text is copied in the above mentioned internet service for counting characters 
106806 - copied and counted in a Zoho document


However, look at the character numbers of the attached files.

Thank you.
Comment 5 Stefan Knorr (astron) 2012-06-28 01:43:15 UTC
This bug should be fixed in 3.6... resolving as duplicate.

*** This bug has been marked as a duplicate of bug 46757 ***