Bug 50596 - "-" takes precedence over "^" contradictory to the mathematical convention.
Summary: "-" takes precedence over "^" contradictory to the mathematical convention.
Status: RESOLVED DUPLICATE of bug 94568
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-01 10:58 UTC by Iddo
Modified: 2020-08-31 12:05 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Iddo 2012-06-01 10:58:26 UTC
When entering "=-3^2" I receive a result of "9". It should be "-9" as the power operator takes precedence over the minus operator, even when the minus operator is unary. 

See: http://en.wikibooks.org/wiki/Arithmetic/Order_of_Operations
This bug appears to be "inherited" from MS-Excel for conformity? http://support.microsoft.com/kb/q132686/
Comment 1 Markus Mohrhard 2012-06-18 09:09:31 UTC

*** This bug has been marked as a duplicate of bug 44076 ***
Comment 2 mwelinder 2018-11-13 19:25:52 UTC
Fixing dupe reference.  This bug is about parsing, not semantics.

*** This bug has been marked as a duplicate of bug 94568 ***