Bug Hunting Session
Bug 50675 - EDITING: Czech spelling does not work in Spreadsheet
Summary: EDITING: Czech spelling does not work in Spreadsheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-04 04:56 UTC by Frantisek Erben
Modified: 2013-06-27 23:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Czech spelling does not work in Spreadsheet (8.54 KB, application/zip)
2012-06-04 04:56 UTC, Frantisek Erben
Details
Working file with Czech Dictionary (7.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-06-27 23:02 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frantisek Erben 2012-06-04 04:56:48 UTC
Created attachment 62501 [details]
Czech spelling does not work in Spreadsheet

Problem description: 
Unable check spelling of Czech text in Spreadsheet.

Steps to reproduce:
1) Open included .ods file and runCheck Spelling (F7)
2) Select Czech 

Current behavior:
Unable select Czech -> allways jump back to English.

Expected behavior:
Automatically select Czech if you have LO in Czech Language or if you have czech language as preffered in Preferences.

Platform (if different from the browser): 
Tested and Occured on Mac OS X 10.7.4 and Windows 7 (I expect that it is multiplatform bug)

Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2
Comment 1 Florian Reisinger 2012-06-04 23:03:02 UTC
Ok, IMHO the problem is quite different: Are you able to select any language,except the default one??
Comment 2 Frantisek Erben 2012-06-05 02:06:45 UTC
I'm working in Czech enviroment - Install LO + Czech additions.
GUI language is in Czech other language preferences is "Default - Czech".

Possible problem in Writer/Spreadsheet…:
Switch User Interface to English (not depend on it).
Switch Locale settings in LO preferences to for exaple "French (Belgium)", but if I switch in Spelling window language to another language "Polish" and click to "Ignore once", spelling select next word but language switch back to default "French (Belgium)".
Comment 3 QA Administrators 2013-05-26 22:32:05 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 4 Joel Madero 2013-06-27 23:01:46 UTC
Interesting enough, it's just this spreadsheet.

Copy and paste the content into another spreadsheet that is set to czech for the document language and it works fine.

Although the one document shows the problem, unless you can figure out how to reproduce with a new document we'll mark as WFM.

Thanks for the report - apologies it took so long to get to.

I attached a document that I created from yours that works right with the Czech dictionary.
Comment 5 Joel Madero 2013-06-27 23:02:02 UTC
Created attachment 81589 [details]
Working file with Czech Dictionary