Bug 50679 - EDITING: Copying cell(s) with conditional formatting CRASH when paste
Summary: EDITING: Copying cell(s) with conditional formatting CRASH when paste
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All Windows (All)
: high critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.7.0 target:3.6.0.0.beta2
Keywords: regression
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-06-04 07:03 UTC by m.a.riosv
Modified: 2012-07-20 22:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document (18.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-06-04 07:30 UTC, Rainer Bielefeld Retired
Details
bt + console msgs on master (8.19 KB, text/plain)
2012-06-09 01:23 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2012-06-04 07:03:57 UTC
Open a new spreadsheet.

1. Enter a conditional formatting in range B2, value: 1, select style:
Result.
2. Enter any value in B2
2. Ctrl-c
3. Select any cell, B2 included.
4. Ctrl-v
5. Crash.

Not reproducible in LibreO 3.5.4rc2
Comment 1 Rainer Bielefeld Retired 2012-06-04 07:19:55 UTC
Already [Reproducible] with parallel installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a502549]" (tinderbox: Win-x86@6-fast, pull time 2012-05-31 07:33:55) 

Was ok with parallel installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7175cee]" (tinderbox: Win-x86@6-fast, pull time 2012-05-16 22:07:37). 

Really rather new and IMHO blocker quality
Comment 2 Rainer Bielefeld Retired 2012-06-04 07:30:07 UTC
Created attachment 62511 [details]
sample document
Comment 3 Julien Nabet 2012-06-09 01:23:48 UTC
Created attachment 62836 [details]
bt + console msgs on master

On pc Debian x86-64 with master sources updated today, I reproduced the pb.
I attached console logs and bt.
Comment 4 Markus Mohrhard 2012-06-09 22:19:46 UTC
Fixed in my local commits, will we pushed with all the other commits for conditional formats/color formats soon.
Comment 5 m.a.riosv 2012-06-10 08:47:54 UTC
Thanks Markus.
Comment 6 Markus Mohrhard 2012-06-10 23:30:00 UTC
Just pushed to master as http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c462b24ab82147211e7e2bee7e6aa98893f429e

Will not be announced by the git bugzilla script because I pushed too many commits at once.
Comment 7 Markus Mohrhard 2012-06-15 09:30:21 UTC
Same problem with 3.6:

After review as late feature now pushed by Kendy as http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-6&id=27e869767c1d0745cdfefcf1cf0c2f76fc74c942

You can now play with color scales and data bars in the upcoming 3.6 beta2
Comment 8 pierre-yves samyn 2012-07-20 10:51:57 UTC
Hello

Still occurs with Version 3.6.0.2 (Build ID: 815c576)

Same crash with :
- Edit> Paste special> Selection: Format
- Format paintbrush

Platform:  windows 7 64bits
Reproduced (fr-discuss) with beta3 and 3.6.0.1

Regards
Pierre-Yves
Comment 9 Markus Mohrhard 2012-07-20 11:01:04 UTC
(In reply to comment #8)
> Hello
> 
> Still occurs with Version 3.6.0.2 (Build ID: 815c576)
> 
> Same crash with :
> - Edit> Paste special> Selection: Format
> - Format paintbrush
> 

This is not the same problem. Please open new bug reports for different problems. As long as the original step by step instruction no longer crashes you should never reopen a bug report.
Comment 10 pierre-yves samyn 2012-07-20 17:29:54 UTC
(In reply to comment #9)
> This is not the same problem. 

?

> Please open new bug reports for different
> problems. As long as the original step by step instruction no longer crashes
> you should never reopen a bug report.

What I did...

Open a new spreadsheet.

1. Enter a conditional formatting in range B2, value: 1, select style:
Result.
2. Enter any value in B2
2. Ctrl-c
3. Select any cell, B2 included.
4. Ctrl-v
5. Crash.

Sorry but I do not understand your reply...
Don't worry : My last attempt to reopen this bug ...

Regards
Pierre-Yves
Comment 11 Rainer Bielefeld Retired 2012-07-20 18:14:00 UTC
I am not able to reproduce a crash with attached sample document and  Server Installation of  "LibreOffice 3.6.0.2 rc  German UI/Locale [Build-ID:  815c576] on German WIN7 Home Premium (64bit), So the original bug (at least the one I reproduced) has been fixed.

Additionally I was NOT able to reproduce Crash due to Comment 8 and comment 10

So closing again. 

@pierre-yves samyn:
> Sorry but I do not understand your reply...

You reopened with something like "Format Paintbrush", what did not sound like the original report. 

What of the for words "is not the same" do you not understand ;-)

If the developer tells you that he doubts that your observation has to do with the original report and asks you to submit a new bug, you should follow his advice instead of reopening the existing bug. 

<https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>

Please submit a new bug for the problem you observed with a more detailed description and a sample document. Please add me to CC there.
Comment 12 Markus Mohrhard 2012-07-20 22:06:07 UTC
If you have a bug report there please open a new bug report and just cc mw. The problem that has been mentionend in this bug report is fixed. I'm sure that there are more problems but it makes it even more difficult for all of us if we track different problems( even if not you don't see the differences between the bugs ) in the same bug report.