Bug 50691 - Writer opens some RTF files very slow
Summary: Writer opens some RTF files very slow
Status: RESOLVED DUPLICATE of bug 44736
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
Depends on:
Reported: 2012-06-04 12:12 UTC by Roman Podolyan
Modified: 2013-12-05 15:45 UTC (History)
0 users

See Also:
Crash report or crash signature:

File 1 in question (117.99 KB, application/x-7z-compressed)
2012-06-04 12:24 UTC, Roman Podolyan

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Podolyan 2012-06-04 12:12:45 UTC
After installation of LibreOffice 3.5.4 I made a comparison of file open time in LibreOffice Writer and Apache OpenOffice 3.4 Writer

These particular RTF files were opened in LO very slow, 6-12 times longer than with AOO.

My friends also tried to open them (in other OSs too) and confirmed the issue, so I think that it is OS-independent.

Feel free to contact me if you need more information or need more testing.
Comment 1 Roman Podolyan 2012-06-04 12:24:34 UTC
Created attachment 62535 [details]
File 1 in question
Comment 2 Roman Podolyan 2012-06-04 13:08:59 UTC
Second slow loading file uploaded to http://depositfiles.com/files/xbq4ciuxu
Comment 3 Urmas 2012-06-21 06:15:43 UTC
Confirming in 3.5.5. That is probably another outbreak of russophoby from developers.
Comment 4 Miklos Vajna 2012-10-15 11:36:32 UTC

We already have bug 44736 for RTF import performance problems. Please also try 3.6, it should be faster, even if it's still a bit slower than it was in LO 3.4.



*** This bug has been marked as a duplicate of bug 44736 ***