Download it now!
Bug 50727 - FORMATTING: Wrong space between lines when creating formula with temporary "?".
Summary: FORMATTING: Wrong space between lines when creating formula with temporary "?".
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 53372 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-05 06:30 UTC by Adam
Modified: 2015-02-19 16:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam 2012-06-05 06:30:30 UTC
Problem description: When using formulas, Writer applies space between lines according to formula height. The problem is that it remembers highest value of it, when entering. So when I enter formula slowly, that it will show me what I typed so far, it is common to get many red "?" and sometimes increased height, it's ok since when I finish it will come back to normal. The problem appears when I want to come to the next line, Writer remembers the formula height when it had many "?" and makes way too big space between lines. The quickest way to fix that wrong space, is either right click formula -> anchor -> To paragraph and right click formula again -> anchor -> As Character. So the anchor setting is the same, but space between lines is correct. Another way to fix it is to reload the file or just simply write something after the formula. Note that the problem occurs only when formula is the first element in line, if it's preceded by any sign (i.e a letter or even "space") the problem won't occur.

Steps to reproduce:
Because the problem depends on the fact if user writes fast or slow (or correct/incorrect) The *PAUSE* in the steps below, means not to make any input for 1 second, so the writer will create a preview of what was entered so far.
1. Create new document
2. Insert -> Object -> Formula (Make sure that created formula is the first element in line[not preceded by a letter or something like that])
3. Type: "x = left ( "
4. *PAUSE* (wait for preview and "?")
5. Type: "sqrt{4"
6 *PAUSE* (wait for preview and new "?")
7. Type: "} right )"
8. Finish creating formula
9. After the formula is entered press enter to go to new line(don't press anything else since any input besides enter will fix the gap), notice the cursor is way under previous line, creating a gap in document.

P.S The full text in formula is "x = left ( sqrt{2} right)". If user writes it fast enough not giving a chance for Writer to create a preview with "?" the problem won't occur.

Expected behavior: 
Next line is right under the bottom of previously created/edited formula.

Additional comment:
I know the problem is cosmetic, and occurs rather rarely, but since I'm using complicated formulas a lot, this problem has been bothering me for some time now, as when I edit formulas followed by a lot of text and objects, it pretty much destroys a lot of order...

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Juan Canham 2012-12-23 18:48:40 UTC
Confirmed on Version 3.6.2.2 (Build ID: 360m1(Build:2)) on Kubuntu 12.10

Thanks for the very detailed instructions, I haven't used the formula editor before so it's only due to your thoroughness that I can confirm this bug.

Thanks, Juan
Comment 2 sas1981 2013-03-12 19:40:47 UTC
*** Bug 53372 has been marked as a duplicate of this bug. ***
Comment 3 QA Administrators 2015-02-19 15:46:17 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 4 Adam 2015-02-19 16:38:59 UTC
This bug is not present anymore in new version. I'm using LibreOffice 4.4.0.3 on Windows 7.