Bug 53372 - undefined: big space between for formula and text
Summary: undefined: big space between for formula and text
Status: RESOLVED DUPLICATE of bug 50727
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: Other All
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2012-08-11 11:03 UTC by sas1981
Modified: 2013-03-12 19:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

screenshort snippet which shows the described bug (15.32 KB, image/png)
2012-08-11 11:03 UTC, sas1981
Screenshot of writer showing the gap between the formula and the next line (11.15 KB, image/png)
2013-03-12 14:41 UTC, sas1981

Note You need to log in before you can comment on or make changes to this bug.
Description sas1981 2012-08-11 11:03:41 UTC
Created attachment 65421 [details]
screenshort snippet which shows the described bug

Problem description: 
After inserting a formula with more than 1 line into a writer document there is a big gap between the formula and the following paragraph.
Steps to reproduce:
1. insert a formala with more than one line into a writer document
2. immediately after closing the formula editor press enter without inserting any character or space behind the formula in the writer document
3. the space between the formula and the following paragraph after pressing enter ist far too big but varies undpredictable

Current behavior:
problem does not occur if a space is inserted after the formula and than enter is pressed

Expected behavior:
no gap between inserted formula and following paragraph

Platform (if different from the browser): 
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 A (Andy) 2012-12-25 21:55:22 UTC
not reproducible with LO (Win7 Home, 64bit)

Steps done:
1. Opened WRITER
2. Chosen OBJECT -> FORMULAR from the menu INSERT
3. Written "X=A+B newline =C+D"
4. Put the cursor directly after the formular and pressed the enter key
5. Typed any word
Comment 2 bfoman (inactive) 2013-03-12 13:30:56 UTC
Checked with:
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Could not reproduce. Tried different formulas from Math Help with newlines. Spacing normal and the same at every try.

Please check if this bug is reproducible with the latest stable release.
Comment 3 sas1981 2013-03-12 14:41:45 UTC
Created attachment 76405 [details]
Screenshot of writer showing the gap between the formula and the next line
Comment 4 sas1981 2013-03-12 14:44:15 UTC
I tried it again with LO running under Windows 8 pro. The bug is still there.
With multiple lines I acctually meant fractions not newlines. Sorry for that. I should have been more exact.

I attached a screenshot of writer showing the problem. Below the 1st and 3rd formula the gap can be seen. The second formula is just for comparission.

1st formula: abs {{a+b} over {c+d}}
2nd formula: a+b
3rd formula: sqrt{{a+b} over {c}} + d

When you insert any character or space behind the formula the gap suddenly disappears.
Comment 5 Adam 2013-03-12 19:19:59 UTC
I can confirm this one, it's actually really tricky, and I described it earlier here https://www.libreoffice.org/bugzilla/show_bug.cgi?id=50727

The key to reproduce this bug is to write formula slowly, so that LO has chance to create thoose red question marks, the more question mark appear making high formula frame, the bigger the space will appear. Easy way to reproduce it is to write half of the formula You presented, so that there are some question marks on preview, then backspace all and write x=4, the space between lines will be much bigger.

I found that bug really annoying but the space trick after formula made it quite easy to live with ;)
Comment 6 sas1981 2013-03-12 19:40:47 UTC
Ah, I've never really showed any attention to the question marks but now that you pointed it out it makes sense.

Thanks for the confirmation.

*** This bug has been marked as a duplicate of bug 50727 ***