Download it now!
Bug 50735 - copy / paste changes page format
Summary: copy / paste changes page format
Status: RESOLVED DUPLICATE of bug 46669
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-05 07:58 UTC by jlader
Modified: 2013-05-27 11:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jlader 2012-06-05 07:58:47 UTC
If I copy text from an outside source, as in a .pdf, pretty much any outside source, and paste it into writer, it changes the page format, in particular the margin settings get set to 1.25" all around.  If I copy from another .odt file and paste, it does not create the problem.  This was not an issue in the 3.4.5 and earlier releases.
Comment 1 Peter 2012-06-25 19:42:29 UTC
Not only does pasting from a pdf mess with the margins, if you try to paste from a pdf in between existing text, it will paste it at the end of the file instead. Also some pdf text pasted becomes stubbornly formatted, making clear format useless as it turns it into large bold characters. Basically whatever new code was introduced for pasting in the releases since the grammar checker was introduced is buggy.
Comment 2 Vlad Lungeanu 2012-10-15 13:11:21 UTC
I had the same problem with version 3.6.2.2 (x86) on x64 Windows 7.

I have managed to solve it by disabling the experimental features (Tools/Options/LibreOffice/General/Enable experimental (unstable) features). The problem seems to appear when using Paste Special/Formatted text [RTF], no matter the source (mine was a CSV opened in Calc, not even another software).
Comment 3 Urmas 2013-05-27 11:53:04 UTC

*** This bug has been marked as a duplicate of bug 46669 ***