Bug 50747 - JDBC connector with subforms do not work, when there is no value in mainform (PostgreSQL, MySQL ...)
Summary: JDBC connector with subforms do not work, when there is no value in mainform ...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 56358 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-05 13:24 UTC by Matt Wheeler
Modified: 2013-04-15 08:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Wheeler 2012-06-05 13:24:15 UTC
If I select the "JDBC" type of connection and enter a URL for my MySQL database, subforms stop working. This happens both for forms generated with the wizard and forms built from scratch in design view.

If the "MySQL (JDBC)" connection type is used instead, the same form with subforms works perfectly (however, this connection type does not support storing a password for the database, so it is unsuitable for my use case).

The error messages displayed when clicking on "More detail" are:


Error:
The data content could not be loaded.


Error:
SQL Status: S1009

Parameter index out of range (1 > number of parameters, which is 0).


Information:
The SQL command leading to this error is:

SELECT * FROM `prm_test`.`addresses` WHERE ( `personID` = :link_from_ID )
Comment 1 Jochen 2012-08-28 18:52:18 UTC
@Robert,

please: have a look at this bugreport. Can you confirm the behavior?
Comment 2 Robert Großkopf 2013-01-22 20:42:26 UTC
Have tested it with MySQL and JDBC (not the JDBC integrated, as described) Seems to be the same problem as reported with PostgreSQL and JDBC. Must be the JDBC-driver of LO.
I will mark
https://bugs.freedesktop.org/show_bug.cgi?id=56358
as a duplicate of this bug and change the titel to all connections of databases with JDBC.
Comment 3 Robert Großkopf 2013-01-22 20:45:16 UTC
*** Bug 56358 has been marked as a duplicate of this bug. ***
Comment 4 Robert Großkopf 2013-01-22 20:48:48 UTC
Changed the version to LO 3.3.4. It the same behavior in all LO-versions I have tested - the eldest version is LO 3.3.4.
Comment 5 Lionel Elie Mamane 2013-04-15 08:36:54 UTC
In menu Edit / Database / Advanced Settings, tab "Special Settings", check the box next to "Replace named parameters with '?'"