Bug 50795 - FORMATTING: Drawing issue with image-based list bullets
Summary: FORMATTING: Drawing issue with image-based list bullets
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: ImpressDraw-Styles
  Show dependency treegraph
 
Reported: 2012-06-06 12:39 UTC by Alexey
Modified: 2021-12-10 20:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example with your license document (some changed) (273.60 KB, image/jpeg)
2012-06-06 12:39 UTC, Alexey
Details
Document to test (22.01 KB, application/vnd.oasis.opendocument.text)
2021-12-10 19:15 UTC, Alexey
Details
Screenshot of LibreOffice v7.2.4.1 (Win64) with this bug (115.78 KB, image/png)
2021-12-10 19:19 UTC, Alexey
Details
Screenshot of LibreOffice v3.3.0 (Portable) with this bug (80.94 KB, image/png)
2021-12-10 19:21 UTC, Alexey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey 2012-06-06 12:39:58 UTC
Created attachment 62680 [details]
Example with your license document (some changed)

Problem description: 
If I use image markers for lists, there are white lines appears on the document's background when scrolling. Usually it's temporarily, and normalized after 1-2 seconds, but sometimes it can be healed only with manually provoke to redrawing this part (for example, by text selection).

Steps to reproduce:
1. Set page background to non-white
2. Set list bullet to any image
3. Scroll the document

Current behavior:

Expected behavior:

Platform (if different from the browser): Windows XP, Linux Mint 13
              
Browser: Opera/9.80 (Windows NT 5.1; U; ru) Presto/2.10.229 Version/11.64
Comment 1 A (Andy) 2012-12-25 11:25:17 UTC
reproducible with LO 3.6.4.3. (Win7 Home, 64bit)

reproduced by the following steps:
1. Opened WRITER
2. Went to PAGE from the menu FORMAT
3. Went to the tab BACKGROUND and set the background color to for instance red
4. Wrote several lines of text
5. Selected all the typed lines of text and went to BULLETS AND NUMBERING from the menu FORMAT
6. Went to the tab GRAPHICS and chose any graphics bullet

The white lines appear on the document's background when scrolling and in my case they even do not disappear.  As in the bug report commented these white lines disappear when selecting the text or putting the cursor anywhere in the text.  When choosing the "normal" bullets and numbering from the tabs BULLETS and NUMBERING TYPE this bug does not occur.
Comment 2 A (Andy) 2014-09-28 17:14:57 UTC
Reproducible with LO 4.3.2.2 (Win 8.1)
Comment 3 QA Administrators 2015-10-14 19:57:04 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-12-04 16:35:51 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2017-01-03 19:41:27 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2019-12-03 14:02:59 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2021-12-03 04:25:43 UTC Comment hidden (obsolete)
Comment 8 Alexey 2021-12-10 19:15:37 UTC
Created attachment 176851 [details]
Document to test
Comment 9 Alexey 2021-12-10 19:19:58 UTC
Created attachment 176852 [details]
Screenshot of LibreOffice v7.2.4.1 (Win64) with this bug
Comment 10 Alexey 2021-12-10 19:21:10 UTC
Created attachment 176853 [details]
Screenshot of LibreOffice v3.3.0 (Portable) with this bug
Comment 11 Alexey 2021-12-10 19:26:48 UTC
This bug is still present in newest version of LibreOffice:

Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded

On my screenshot you can see some small white lines and one large white rectangle. Small lines appeared when I used mouse wheel, large rectangle - when I slow moved thumb of vertical scrollbar.

LibreOffice v3.3 has same issue (tested on Portable version).