Bug Hunting Session
Bug 50800 - EDITING: queries do not filter when created with the query wizard
Summary: EDITING: queries do not filter when created with the query wizard
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All All
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:3.7.0 target:3.6.0.2 target:3.5.6
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-06 14:50 UTC by Christopher
Modified: 2012-07-23 16:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Composite screenshot of bug (69.67 KB, image/jpeg)
2012-06-06 14:50 UTC, Christopher
Details
Our food inventory (20.75 KB, application/vnd.sun.xml.base)
2012-06-30 08:15 UTC, Christopher
Details
Query-wizard in 3 versions of LO: correct only in LO 3.3.4 (18.43 KB, application/vnd.sun.xml.base)
2012-07-12 06:22 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher 2012-06-06 14:50:20 UTC
Created attachment 62683 [details]
Composite screenshot of bug

I am trying to use LibreOffice for household food inventory and price reckoning. I have a spreadsheet (via Calc) with the primary data in it, which I have imported into a database table (via Base).

When I create a query using the Query Wizard in Base, which SHOULD filter the table so that e.g. only Dairy items show, it instead returns ALL RECORDS in the entire table. I am fairly certain that I am creating the query correctly.

Can someone cue me into what is wrong? (Honestly, I hope it's a PEBCAK error.)

I have attached a composite screenshot of the issue.
Comment 1 Christopher 2012-06-24 16:12:15 UTC Comment hidden (no-value)
Comment 2 Alex Thurgood 2012-06-30 04:33:40 UTC
(In reply to comment #1)
> OK, obviously you folks don't care much about bugfixes. This has been open for
> something like two and a half weeks, and no attention has yet been given.
> 
> I'll just go find another office suite, hopefully one that *works*.
> Congratulations on "resolving" a bug by losing a customer.

Did you pay for the use of this software ? If not, then you are not a customer, merely a user, and an obviously dissatisfied one. Nonetheless, you are not a customer.

If you did pay for it then, you have been done, LibreOffice is free (both as in beer, and in the rights conveyed in the software), and you should take your quibble up with whoever managed to con you into spending money to download and install it.

Now, as a user of a free (as in monetarily free) and volunteer driven project, you might feel disgruntled at a certain functionality not working. However, that gives you absolutely no right to demand that any problem be solved in any sort of time frame. You could express your desire for it to be done, you might even be able to help resolve the problem (if there is actually a problem), but that is about as far as your demands can go.

If you had read up on the bug submission process, you would have noticed that most reports require a step by step detailed instruction of how to reproduce the behaviour you consider buggy. In addition, a sample file, or at least a script enabling the database to be reproduced, and the query used, would be more than helpful. You have done neither of these things, yet are content to gripe at the alleged slowness of the bug triaging process.


Even paid-up software with a telephone help desk system would require more information than you have given in order to even attempt to help you.

Alex
Comment 3 Alex Thurgood 2012-06-30 04:39:20 UTC
The image you have posted is of such low resolution that I can not usefully read any of the details, even when I zoom in.

Additionally, if you seriously want anyone to look at the problem you have, please provide us with a sample database and detailed steps to reproduce the problem.


Alex
Comment 4 Christopher 2012-06-30 08:15:28 UTC
Created attachment 63644 [details]
Our food inventory

This is our inventory. Yes, we have a lot of food.
Comment 5 Christopher 2012-06-30 08:25:26 UTC
I didn't think I'd get an answer! (and I'm honestly surprised that I did.) For the record, it's been 24 days or so since I first submitted this -- three weeks, three days. Hmmm... maybe you folks might consider a support forum as well as the buglist? Just sayin'. BTW, I only knew about the response because Bugzilla sent me like four emails all at once with the different changes.

I've uploaded our database. It is created from a spreadsheet, courtesy of instructions in an online article that I've since lost. The operation goes like this, to create the database...

(1) Select all cells in the spreadsheet (CTRL+A)
(2) Run LO Base. In the "tables" screen, right click in an empty area, and select "Paste".
(3) Accept the default values and settings in the Table Creation Wizard Thingy that pops up.
(4) There is no step 4, it's done.

According to what I recall of the article, that should allow full database functionality to the contents of the spreadsheet. If you folks want, I can upload the spreadsheet at some point.

In order to generate a query, I use the Query Wizard (I'm not smart enough to make it in design view!). "Type of Food" gets set to "Dairy". Sort by the "Key" field, ascending. Those are the only things I set. If it works, I'll be amazed. It gives me a SQL Syntax Error no matter what the heck I do.

I will also mention that I've got like five or six different Java installs, because they don't uninstall the old one when the new one's stuck in there. Not sure what gives with that, but it occurs to me that this might be causing a problem somehow.
Comment 6 Robert Großkopf 2012-07-12 06:22:44 UTC
Created attachment 64132 [details]
Query-wizard in 3 versions of LO: correct only in LO 3.3.4

There is a bug in the wizard of LO. In LO 3.3.4 it works. The table is filtered by the term you wish. Then I tried this with LO 3.5.5 and LO 3.6.0 Beta 3 - there was only shown the whole table, no condition for filtering the values.
Comment 7 Robert Großkopf 2012-07-12 06:24:54 UTC
I will change the Status to "New" and the bug-title, because queries work right in LO 3.5 and other versions, but not the filter in the wizard for queries.
Comment 8 Christopher 2012-07-12 06:35:56 UTC
Then, having seen that, I will work for now in LO 3.3.4. When a patch is made for a current version (which right now is probably a future version) I will switch to something newer.

Thank you both for your help so far. I hope a patch can be made. Alas, I can but test it -- I am by no means a programmer of any substance!
Comment 9 Alex Thurgood 2012-07-12 09:14:54 UTC
(In reply to comment #8)
> Then, having seen that, I will work for now in LO 3.3.4. When a patch is made
> for a current version (which right now is probably a future version) I will
> switch to something newer.


Yes, that is probably the best course, and is why I still keep a 3.3.4 version here on my Mac. However, there have been bugfixes in Base during 3.5 development that relate to bugs in the 3.3.x and 3.4.x development lines. I suppose it always boils down to what you can/can't live with.


> 
> Thank you both for your help so far. I hope a patch can be made. Alas, I can
> but test it -- I am by no means a programmer of any substance!

Don't worry about that, I'm not a developer either, but we can all help in some way - thanks for your input !

Alex
Comment 10 Alex Thurgood 2012-07-12 09:17:44 UTC
Hi Lionel,

Assigning to you, could you take a look ? 

Seems like we lost the ability to filter via the Query Wizard somewhere during 3.4.x/3.5.x development.


Alex
Comment 11 Alex Thurgood 2012-07-12 09:18:39 UTC
Editing title to be more specific

Filtered queries work in general, just not when they are created via the Query Wizard.

Alex
Comment 12 Lionel Elie Mamane 2012-07-12 13:29:57 UTC
Reproduced in my dev tree
Comment 13 Not Assigned 2012-07-12 21:40:43 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ede56437f9641cad698b97b2dd14b0c1c37dfcce

fdo#50800 populate composedCommandNames ASAP, not at call of getFromClause
Comment 14 Christopher 2012-07-14 21:48:24 UTC
Hey, how big is that patch? I tried to download it but it didn't finish -- my Internet connection is a little tenuous (not dialup though, thankfully!).
Comment 15 Lionel Elie Mamane 2012-07-15 05:10:00 UTC
(In reply to comment #14)
> Hey, how big is that patch?

Less than 4kB.
Comment 16 Christopher 2012-07-15 11:50:39 UTC
That's odd. The file on the patch-page, core-ede56437f9641cad698b97b2dd14b0c1c37dfcce.zip, is a LOT bigger, over 100mb. How can I download and apply JUST the patch? or do I need the whole tamale that's in the *.zip mentioned above?
Comment 17 Lionel Elie Mamane 2012-07-15 13:22:00 UTC
(In reply to comment #16)
> That's odd. The file on the patch-page,
> core-ede56437f9641cad698b97b2dd14b0c1c37dfcce.zip, is a LOT bigger, over 100mb.

That's the whole sources.

> How can I download and apply JUST the patch?

I assume you already have the full LibreOffice sources, and know how to build. In the absence of further information, I also assume a Unixy environment.

Click on "patch" in parentheses on the line:

 commit	ede56437f9641cad698b97b2dd14b0c1c37dfcc (patch) (side-by-side diff)

1) Save that as /some/file/name
2) cd /where/you/put/the/libreoffice/sources
3) patch -p1 < /some/file/name
4) make && make install
Comment 18 Christopher 2012-07-15 13:36:54 UTC
Sadly, no. Windows XP service pack 3, and no sources -- nor the proper environment for compiling them (or the knowledge to do so). I am by NO means a capable programmer!

My ONLY programming experience is in QBASIC of all things -- I wrote a horribly-designed parserless text adventure (it's almost literally more if-then statements than it is anything else!) in that language, ONCE. I decided after that, that I'd done enough.

Then again... TBH, if you gave me bonehead-proof step-by-step instructions for compiling, in Windows (as noted above), with the patch, AND it isn't terribly hard or complex... I might be able to do it. But if there are ANY errors in compiling, I'm not going to know how to handle them!

I hope my ASUS netbook can handle it... Atom N270 CPU, 2gb RAM (I upgraded it).
Comment 19 Not Assigned 2012-07-16 14:02:07 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a7c0710cc063912d912cc95b10415bc717a241f&g=libreoffice-3-6

fdo#50800 populate composedCommandNames ASAP, not at call of getFromClause


It will be available in LibreOffice 3.6.
Comment 20 Not Assigned 2012-07-23 14:10:23 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5b6a945e898ded83613afefbedef71372665b13&g=libreoffice-3-5

fdo#50800 populate composedCommandNames ASAP, not at call of getFromClause


It will be available in LibreOffice 3.5.6.
Comment 21 Christopher 2012-07-23 16:16:48 UTC
Great, thanks! I'll poke you guys again if the patch doesn't work (although I have every expectation that it will). Looking forward to trying it out.