Download it now!
Bug 50817 - Thumbnail overlay to start presentation, disable slide or duplicate it is in wrong position
Summary: Thumbnail overlay to start presentation, disable slide or duplicate it is in ...
Status: RESOLVED DUPLICATE of bug 51231
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 01:31 UTC by daniel.schaaaf
Modified: 2012-06-20 22:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Bug in slide thumbnail overlay positioning (264.10 KB, application/vnd.oasis.opendocument.text)
2012-06-07 01:31 UTC, daniel.schaaaf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.schaaaf 2012-06-07 01:31:28 UTC
Created attachment 62698 [details]
Bug in slide thumbnail overlay positioning

The slide thumbnail overlay that allows us to start the presentation, disable a slide or duplicate it, is getting in the user's way! This can be seen in the attached file.
The overlay gets activated when the mouse cursor is hovering over a thumbnail. The (buggy) position of the overlay seems to depend on the "point of entrance" onto the thumbnail. Dragging the mouse cursor over a thumbnail from the top makes the overlay appear at its bottom. But the "point of entry" doesn't say anything about where the user stops moving the mouse! If the mouse cursor enters from top but stops at the bottom, then the overlay will appear under the mouse cursor. If the user then clicks on the thumbnail to activate/edit the slide, he clicks on the overlay instead and performs an action that he didn't intend to perform (like disabling the slide).

This is another fine example of an automatism that is supposed to help but instead results in unexpected behaviour.

Firstly, the overlay should be optional and the user should be able to disable it! That could be achieved by providing a "disable overlay" option in a "right click context menu" for the overlay and an additional entry in the options window.
Secondly, the position of the overlay should depend on the position of the mouse cursor! Display of the overlay should be triggered by dragging the mouse cursor over a slide thumbnail, but the position of the overlay should depend on the position of the mouse cursor at the time when the overlay is appearing!
Comment 1 Rainer Bielefeld Retired 2012-06-20 22:00:42 UTC
DUP, for details please see my Comment 6 in Bug 51231!

*** This bug has been marked as a duplicate of bug 51231 ***