Bug Hunting Session
Bug 50863 - EDITING: Oracle Java 1.7.0_04 is not compatible with the Writer of LibreOffice 3.5.4.2 on the Windows platform
Summary: EDITING: Oracle Java 1.7.0_04 is not compatible with the Writer of LibreOffic...
Status: RESOLVED DUPLICATE of bug 50371
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 17:58 UTC by mwu
Modified: 2012-06-27 07:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mwu 2012-06-07 17:58:19 UTC
Problem description: 
  It is seemed that Oracle Java 1.7.0_04 is not compatible with
the Writer of LibreOffice 3.5.4.2 on the Windows platform XP + SP3. When we click " File " --> " Send ", the Writer will be forced to get closed even we use a new built user profile. If we use the old version 1.6.0_31, the Writer will function normally. If we disable Java, then we will get a warning once we click " File " --> " Send " and the LibreOffice
will be forced to get closed too.
Steps to reproduce:
1. enable Oracle Java 1.7.0_04
2. open a writer document
3. click " File " --> " Send "

Current behavior:
The Writer will be forced to get closed.
Expected behavior:
We can choose the file type for Email.
Platform (if different from the browser): 
Windows XP + SP3 ( Linux seemed not affected )              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0
Comment 1 V Stuart Foote 2012-06-27 07:18:35 UTC
Can not confirm problem in LibreOffice under Windows. JRE 1.7u4 and JRE 1.7u5 32-bit frameworks both correctly function under 32-bit and 64-bit Windows with LibreOffice 3.5.4 features that require a Java runtime, notably this reports File --> Send actions; and with the Tools --> Accessibility --> Support assistive technology tools (using Java Access Bridge 2.0.2).

However, multiple users have reported issues with LibreOffice function following JRE upgrade--Bug 50371.  These issues are not repaired by JRE and LibreOffice reinstall.

Suspect JRE misconfiguration following upgrade on Windows systems. LibreOffice JRE configuration on Windows is in the javasettings_Windows_x86.xml file from the C:\Users\<username>\AppData\Roaming\LibreOffice\3\user\config directory of each users profile. Suggest review of this XML file for residual JRE settings from prior versions.  Removal and auto-rebuild has helped some users.

Unfortunately, for some even complete removal of LibreOffice user profile has restored JRE function--suggesting JRE misconfiguration is at the system level.

Marking as duplicate of Bug# 50371 (CONFIGURATION: JRE 7.x incompatibility not resolved)

*** This bug has been marked as a duplicate of bug 50371 ***