Bug 50906 - EDITING: AutoCorrect TWo INitial CApitals not working in English UK (or AU)
Summary: EDITING: AutoCorrect TWo INitial CApitals not working in English UK (or AU)
Status: RESOLVED DUPLICATE of bug 53006
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL: https://bugs.freedesktop.org/buglist....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-09 01:00 UTC by Philip
Modified: 2012-09-24 07:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip 2012-06-09 01:00:59 UTC
AutoCorrect Options > Correct TWo INitial CApitals is CHECKED for both [M] and [T] but the error (of two intial caps) is not corrected, despite repeated 'forced' errors to test this feature out. Am using LibO_3.5.4_MacOS_x86_langpack_en-GB. Have tried this with default language set to both English (UK) and English (Australia), but with no success.
Comment 1 Rainer Bielefeld Retired 2012-06-09 02:03:59 UTC
NOT reproducible with "LibreOffice 3.5.4.2  German UI/Locale [Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit) in WRITER.

@Philip:
Can you please check relation to Bugs listed when you do Query in "URL"?
Really only in WRITER?
No Exceptions defined?
Comment 2 Philip 2012-06-09 03:25:43 UTC
(In reply to comment #1)
> NOT reproducible with "LibreOffice 3.5.4.2  German UI/Locale [Build-ID:
> 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit) in
> WRITER.
> 
> @Philip:
> Can you please check relation to Bugs listed when you do Query in "URL"?
> Really only in WRITER?
> No Exceptions defined?

Hello Rainer:
(This is my first Bug post, so apologies if I haven't followed all the protocol..)
Am uncertain what you mean by <check relation to Bugs listed when you do Query in "URL"> ...
Clicking on link in URL: "https://bugs.freedesktop.org/buglist.cgi?list_id=83817&short_desc=TWo%20INitial%20CApitals&query_format=advanced&short_desc_type=allwordssubstr&component=Libreoffice&component=Linguistic&component=Writer&product=LibreOffice" finds 3 similar bugs:
https://bugs.freedesktop.org/show_bug.cgi?id=48088 (relates to Serbian language)
https://bugs.freedesktop.org/show_bug.cgi?id=45546
https://bugs.freedesktop.org/show_bug.cgi?id=40224 (?Closed)
Have since tested & replicated the problem in SPREADSHEET, PRESENTATION & DRAWING files, thus think it is not just restricted to WRITER.

I have checked the Exceptions list, and none of the 'problem' words that I typed appear there. (The sample I used to test was:  "THis is TEsting AUto COrrect")

I am using LibreOffice 3.5.4.2 [Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d18].

Hope this has answered your query.
Philip
Comment 3 Roman Eisele 2012-06-14 09:21:17 UTC
REPRODUCIBLE with LibreOffice 3.5.4.2 (Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18), German langpack installed, on MacOS X 10.6.8 German UI.

Steps used to reproduce:
1) Start LibreOffice
2) New Writer document
3) Make sure that at "Tools > AutoCorrect Options...> Options" for option "Correct TWo INitial CApitals" both the [M] and the [T] checkbox is checked.
3) Type "Test: "
4) Select "Tools > Language > For the paragraph > More..." and select "English (UK)" in the dialog window which appears then.
5) Continue typing: "THis is TEsting AUto COrrect."

Expected behaviour: the text gets corrected to "This is Testing Auto Correct." automatically.

Acutual behaviour: the text appears without any changes as typed, i.e. "THis is TEsting AUto COrrect."
Comment 4 Roman Eisele 2012-09-24 07:03:02 UTC
This looks like the same issue as in bug 53006, “Autocorrection TWo INitial CApitals does not work because of bundled extensions problem”. Of course, bug 53006 was reported for LibreOffice 3.6.0, but the problem could easily have existed already in 3.5.4, as the present report says.

@ Philip (and others):
Bug 53006 should be fixed in the current (LibreOffice 3.6.1) release. Therefore, if you can still reproduce the problem described by the present bug report in LibreOffice >= 3.6.1 on Mac OS X, please reopen the present bug report.

Thank you!

*** This bug has been marked as a duplicate of bug 53006 ***