Bug Hunting Session
Bug 50936 - Link errors in SDK index.html
Summary: Link errors in SDK index.html
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-10 08:32 UTC by Regina Henschel
Modified: 2013-03-22 15:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2012-06-10 08:32:37 UTC
I download SDK and start it's index.html

The link 'C++ reference' points to file:///<myinstall>/sdk/docs/cpp/ref/index.html

But a subfolder cpp does not exist, neither in 'docs' nor elsewhere.

The link 'License' points to file:///<myinstall>/sdk/share/readme/LICENSE_en-US.html

But that file does not exist. There are the files license.txt and readme_en-US.txt
Comment 1 Mas 2012-10-02 05:41:11 UTC
Regina, 

Can you advise on where you are downloading the SDK From. We will also need to know which operating system you are attempting to install it on
Comment 2 Andras Timar 2012-10-02 10:37:07 UTC
Bug is reproducible with LibO-SDK_3.6.1_Win_x86_install_multi.msi. "c:\Program Files\LibreOffice 3.6\sdk\docs\cpp"  is missing. However, on Linux master it is there, az least it is built into the odkcommon.zip in odk/unxlngx6.pro/bin/. So further investigations are needed.
Comment 3 Andras Timar 2012-10-02 16:26:19 UTC
We have two issues here.

1. Missing cpp documentation. That is because release builds on Windows are configured --without-doxygen. Fridrich can tell why it is so, and he can install doxygen to build server.

2. Wrong link to license. I guess it never worked. The problem is that readme and license are called different names under Linux and Windows. I wonder why. Another problem is that we need a short version of the license text, the license of SDK is LGPLv3 I suppose, no need to include the full text including licence of fonts, dictionaries, third party libs etc. I CC Michael, just in case. Maybe we should link MPLv2 when we make the move.
Comment 4 Fridrich Strba 2012-10-02 19:56:42 UTC
I installed cygwin's doxygen on the builder machine. Will run a partial rebuild just to find out whether it works like that
Comment 5 Michael Meeks 2012-10-03 10:35:51 UTC
Chunks of the SDK are BSD licensed; so I'd feel happier shipping the entire license file with it automatically if possible - particularly as we move to MPLv2 on ALv2 with some BSD bits etc.
Comment 6 Not Assigned 2012-10-03 14:58:47 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd7a079918b518710de1ff97e5d2bb621a350f96

fdo#50936 fix link to license file in SDK documentation



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Fridrich Strba 2013-03-22 15:42:37 UTC
Setting to fixed, since it is in LO 4.0