Download it now!
Bug 51013 - ODFF: implement missing imaginary functions
Summary: ODFF: implement missing imaginary functions
Status: CLOSED DUPLICATE of bug 51017
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL: https://issues.apache.org/ooo/show_bu...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-12 10:11 UTC by Regina Henschel
Modified: 2012-06-12 15:05 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
code for IMCOT, IMCSC, IMSEC, IMTAN, IMSINH, IMCOSH, IMSECH, IMCSCH (29.35 KB, patch)
2012-06-12 10:11 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2012-06-12 10:11:48 UTC
Created attachment 62938 [details]
code for IMCOT, IMCSC, IMSEC, IMTAN, IMSINH, IMCOSH, IMSECH, IMCSCH

The origin of this work is in AOO issue id=111609. It is integration in AOO trunk with revision r1348096. It implements the imaginary functions IMTAN, IMCOT, IMSEC, IMCSC, IMSINH, IMCOSH, IMCSCH, IMSECH. Those are defined in ODFF, but not implemented yet. 

I have now transformed it to the attached patch, so it is applicable to LibreOffice. If you like it, you can use it immediately, without waiting for an AOO release.

[I have sent it already to libreoffice@lists.freedesktop.org, but it seems the mail was overseen.]
Comment 1 Eike Rathke 2012-06-12 15:04:58 UTC
Sometimes a review takes a day or two ...
Thanks! Great patch!

*** This bug has been marked as a duplicate of bug 51017 ***