Bug Hunting Session
Bug 51089 - Undo is broken (EDITING)
Summary: Undo is broken (EDITING)
Status: RESOLVED DUPLICATE of bug 37405
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-14 11:20 UTC by Joel VanderWerf
Modified: 2012-06-28 03:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel VanderWerf 2012-06-14 11:20:41 UTC
Undo causes unexpected changes to text in Impress.

To recreate:

1. Open blank presentation.

2. Click in the main text area, where it says "click to add text"

3. Type the characters on the following line (<cr> is carriage return):

aaa<cr>bbb<cr>ccc<cr>

4. click in the first line of text between the first "a" and second "a".

5. Undo three times (either ^Z or Edit/Undo)

6. Text will become a single line: "aaabbbccc"

Note: Undo in LibreOffice Writer seems to work fine.

Repeatable on (x)ubuntu 12.04, x86 and x86-64.
Comment 1 Roman Eisele 2012-06-18 23:25:11 UTC
REPRODUCIBLE with LibreOffice 3.5.4.2 (Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18), German langpack installed, on MacOS X 10.6.8 German.

Following the steps given in the original description, I get the same (wrong) result: a single line of text "aaabbbccc".

-> Changed Platform to "All", because bug is present not only on Linux, but also on MacOS X.

Could someone else please test Windows?
Comment 2 Roman Eisele 2012-06-18 23:27:15 UTC
Also REPRODUCIBLE with LibreOffice 3.6.0beta1 (Build ID: 1f1cdd8), German langpack installed, on MacOS X 10.6.8 German. All the same.
Comment 3 Ivan Timofeev (retired) 2012-06-28 03:55:45 UTC

*** This bug has been marked as a duplicate of bug 37405 ***