Bug 51131 - EDITING: Images should not be moved out of text boundaries ('follow text flow' disabled)
Summary: EDITING: Images should not be moved out of text boundaries ('follow text flow...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Writer-Images Frame Writer-UX Shapes
  Show dependency treegraph
 
Reported: 2012-06-15 14:04 UTC by Colin
Modified: 2017-10-23 08:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Exemple document (45.65 KB, application/vnd.oasis.opendocument.text)
2012-12-24 11:50 UTC, Colin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2012-06-15 14:04:55 UTC
Problem description: 
When you have created a document with formulas and images, you may want to insert a paragraph (text processing programs are done for that). Unfortunately, when you add your text, images are often moved down and go out of the print zone.
So, after you have inserted your new text, you have to manually move the images and formulas so that they go back to the print zone.

It is a quite big loss of time for big documents with no page return.

Current behavior:
Images are moved and my go out of the defined print zone.

Expected behavior:
If images should be moved with the paragraph they are linked to, they should stay in the print zone.

Platform (if different from the browser): Every platform
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Comment 1 Joel Madero 2012-12-12 16:33:06 UTC
I actually am positive that I read the polar opposite on another bug report (where a user got irritated that images couldn't go outside of print zone) but I'll have to dig around to find that bug. 

As for your suggestion, so if an image moves down and it forces it to go out of the print zone, it would then just end up on the next page? I'm not sure how that saves much time if you still have to edit the image to get it back on the original page.

Many thanks for clarifying
Comment 2 Colin 2012-12-24 11:47:35 UTC
Most of the time, the image should stay on the current page but should be automatically blocked by the print zone (it goes up in the paragraph). The basic idea is : as the "out of the print zone" should be empty, there is no reason why the user would want the images to automatically go out of the print zone.
On the contrary, a user should always be able to move an image out of the print zone manually (ie drag & drop).

The image should go to the next page only if the whole paragraph jumps to the next page or if there is really no place left for the image on the current page.
Comment 3 Colin 2012-12-24 11:50:23 UTC
Created attachment 72066 [details]
Exemple document

If you add some extra lines in the paragraph "Nothing", the formula and the OLE object will be moved out of the print zone.
I expect most users don't want this.
Comment 4 retired 2013-11-23 17:58:10 UTC
I agree with Colin that moving the graphic objects out of printing range, isn't a great idea. Imo the objects should be moved to the next page directly instead first going out of print range.

To reproduce: as Colin writes, open test document and enter additional lines after "nothing" text.

Tested with LO Version: 4.3.0.0.alpha0+
Build ID: 73342dbb82ba074d01962359dac50fb2aa36cbeb
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-22_07:09:14

Setting to NEW.
Comment 5 QA Administrators 2015-04-19 03:22:58 UTC Comment hidden (obsolete)
Comment 6 Colin 2015-04-21 11:14:37 UTC
The bug is still present with version 4.2.7.2 (Ubunut 14.04 build, amd64)
Comment 7 QA Administrators 2016-09-20 09:33:28 UTC Comment hidden (obsolete)
Comment 8 Thomas Lendo 2017-06-21 20:46:32 UTC
Joel: Did you mean Bug 92745 - Ability to drag image partially off the page ?
Comment 9 Yousuf Philips (jay) (retired) 2017-10-23 08:01:55 UTC
(In reply to Thomas Lendo from comment #8)
> Joel: Did you mean Bug 92745 - Ability to drag image partially off the page ?

He was likely talking about bug 50206, which bug 92745 is a dupe of.

But the issue here is that frames, images, shapes, OLEs are going into the page margin as 'follow text flow' is disabled in the properties dialog, which users can enable if they dont like this default behaviour.