Bug 51199 - CONFIGURATION: custom hotkeys for submenu items do not work
Summary: CONFIGURATION: custom hotkeys for submenu items do not work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-18 02:55 UTC by RSC
Modified: 2016-09-20 12:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RSC 2012-06-18 02:55:24 UTC
I have succesfully assigned about 20 keys to various purposes in Writer.

I can assign keys to Application>Recent Documents, but when I try them, nothing happens.

Examples CTRL-INS and CTRL-SHIFT-O.


Possibly relevant that I have tried to write a macro to do the job. In general macro recording does work ('Enable experimental (unstable) features' is on) but the sequence 'ALT-F u', with or without choosing a specific document and NTR, gets no offer to save.
Comment 1 tommy27 2012-12-28 09:09:42 UTC
I confirm that any hotkey assigned to "Application>Recent Documents" does nothing.
tested on LibO 3.6.4 and LibO 4.0 beta2 using Windows Vista 64bit.

however I wonder if it ever did something... I mean, "Recent Documents" is just a submenu item of the toolbar "File" tab... probably it can be accessed only by mouse clicks and cannot be opened directly by an hotkey or macro.

does anybody have earlier LibO releases (3.3.x or 3.4.x) to test and see if it ever worked?

if not, probably this could be labeled as NOTABUG, but I think that that item (and others which have no effect) should be removed from the "customize keyboard" menu to avoid confusion.
Comment 2 tommy27 2012-12-28 19:22:52 UTC
confirmed on 3.5.4... but I suppose it has always been like that even on 3.3.x 

so changed SUMMARY, VERSION and COMPONENT and PLATFORM

basically some submenu items like:
"File/Recent Documents"
"File/Wizards"

are shown in the Customize/Keyboard/Functions list and can be assigned to hotkeys, which however will have no effect at all since these submenu items can be opened just with mouse and manual selection.

so I see 2 possible solutions:

1- do not offer those items from the key customizer and remove them from the list to avoid confusion among users

2- make the hotkey work, opening the File Menu with focus on the proper submenu item
Comment 3 manj_k 2013-01-02 11:25:40 UTC
"Tools > Customize > Keyboard > Application > Recent Documents > Shortcut key" has never worked (LibreOffice/OpenOffice.org).

Adjusted: "Version: unspecified".
Comment 4 bugquestcontri 2013-01-03 07:15:02 UTC
this is a linked enhancement request

I tried several times to have the submenu "Recent Documents" to be placed in the menu bar or a toolbar but failed

For people using "Recent Documents" often like me, a direct access in the menu bar to "Recent Documents" would be nice including a little bit wider window to see longer file names
Comment 5 tommy27 2013-01-04 12:57:09 UTC
(In reply to comment #3)
> "Tools > Customize > Keyboard > Application > Recent Documents > Shortcut
> key" has never worked (LibreOffice/OpenOffice.org).
> 
> Adjusted: "Version: unspecified".

reverting version to 3.3.0 beta2

I asked to the QA guys and they told me that if a bug as always been present (even those inherited from prior OOo versions) the correct label is 3.3.0 beta2.
Comment 6 RSC 2014-01-12 09:30:37 UTC
Thanks for the comments and discussion. Removing the hotkey option for this and any other similar possibilities seems like the most immediaetly helpful solution (if easy to do).

Meanwhile I have moved the 'Recent documents' to the top of the File menu, so ALT-F then right arrow gets the drop down submenu. Only one extra click.
Comment 7 tommy27 2014-01-12 09:43:40 UTC
(In reply to comment #6)
> ....  Removing the hotkey option for this
> and any other similar possibilities seems like the most immediaetly helpful
> solution (if easy to do).
> 
> ...

I agree. When you have an option that does not work, you have 2 choices:
1- make it work
2- remove it as an option
Comment 8 Joel Madero 2015-05-02 15:44:26 UTC Comment hidden (obsolete)
Comment 9 RNW 2015-05-04 18:42:37 UTC
Mint 17; LibreOffice 4.4.2

I was the author of this bug report. Same behaviour as before, but earlier discussion concluded that this isn't a bug: it was never possible.

I have moved 'Recent Documents' to the top of my File menu, and that is a good enough  solution for me.

There was a suggestion that 'Recent Documents', whichis available under Tools >  Customise > Keyboard > Application be removed from the offerings for shortcut keys, but that has not been done. It would be useful to remove it if that isn't difficult, and there wouldn't be side effects.
Comment 10 QA Administrators 2016-09-20 09:38:14 UTC Comment hidden (obsolete)
Comment 11 RNW 2016-09-20 10:35:09 UTC
RESOLVED-WORKSFORME

I hope this clears it off your list. The conclusion was that it isn't really a 'bug' at all, more a feature of the design. I'm happy with the workaround I described.

Thanks for the attention.