Download it now!
Bug 51201 - UI: Command-V doesn't paste in search field
Summary: UI: Command-V doesn't paste in search field
Status: RESOLVED DUPLICATE of bug 49853
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-18 03:49 UTC by mark
Modified: 2012-06-18 15:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Active search field, value pasted in the wrong place. (12.30 KB, image/png)
2012-06-18 03:49 UTC, mark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mark 2012-06-18 03:49:36 UTC
Created attachment 63171 [details]
Active search field, value pasted in the wrong place.

Problem description: 
When I paste a value from the clipboard (using keyboard shortcut: command-V) when the search field is active, the value still gets pasted in the spreadsheet instead of in the search field.

Steps to reproduce:
1. Cut/Copy something into your clipboard (for example cut the value from a cell in the spreadsheet by clicking on it and pressing command-X)
2. Select a (different) visible cell in the spreadsheet (by clicking on it)
3. Activate the search field (either by pressing command-F or by clicking edit > find, confirm that the search field is active by typing something and having it appear in the search field)/
4. Paste the content of your clipboard (by pressing command-V)

Current behavior:
The pasted value (step 4) goes into the currently selected cell on the spreadsheet, not in the active search field.

Expected behavior:
The pasted value (step 4) goes into the active search field, not into the selected cell on the spreadsheet.

Platform (if different from the browser): 
Mac OS X (Lion: 10.7.4)
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5
Comment 1 Rainer Bielefeld Retired 2012-06-18 14:11:51 UTC
NOT reproducible with "LibreOffice 3.5.5.1  German UI/Locale [Build-ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8] on German WIN7 Home Premium (64bit) 

MAC specific? Fixed?
Comment 2 mark 2012-06-18 15:39:32 UTC

*** This bug has been marked as a duplicate of bug 49853 ***