Bug Hunting Session
Bug 51247 - EDITING: CRASH when modify Text Animation properties to "As one object" and check "Animate attached shape" option
Summary: EDITING: CRASH when modify Text Animation properties to "As one object" and c...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.1 RC1
Hardware: Other Windows (All)
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:3.7.0 target:3.6.4 target:3.5.8
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-06-20 01:08 UTC by Rainer Bielefeld Retired
Modified: 2012-10-26 16:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-06-20 01:08:27 UTC
Steps how to with Master " 3.7.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 1d1c70d]" (tinderbox: W2008R2@20, pull time 2012-06-18 08:23:14) (due to AOOo report):

1.Launch LibO, 
2. New Presentation document form LibO Start Center
3. Input a character into the title textbox.
4.Click on the blank space to exit edit mode
5. select the title textbox (If you have "Quick Edit" enabled, you will have 
   to press <esc> to leave Edit mode and to get the control points of the 
    text box)
6. Switch to Tasks Sidebar, add Custom Animation 'Entrance - Expand' <ok>
7. Switch to 'Custom Animation' sidebar panel, select the effect 
   created in step 6, then click the 'Effect Options' button (shown as "...").
8. In "Effect Options" dialog switch to "Text Animation" tab, select 
   'Group text->All paragraphs at once',<ok>.
9. Select the animation effect on Task panel, open 'Effect Options' dialog again, 
   switch to 'Text Animation' tab, select 'Group text -> "As one object"'
10. check "Animate attached shape"
11. <OK>
   > CRASH
Comment 1 Rainer Bielefeld Retired 2012-06-20 01:28:58 UTC
NEW, ALL OS due to AOOo Bug

Already [Reproducible] with 
"LibreOffice 3.4.1RC1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:101)]" 

Seems that problem came with 3.4.0, so Regression

Still works fine with
LibO 3.3.3
OOo 3.2-dev

Dataloss / Crash, only major because not a very plausible user scenario.

Crash reproducible with LibO 3.5.3 / Ubuntu 12 (VirtualBox)

@rodo:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept
this Bug.
Comment 3 Not Assigned 2012-07-05 13:15:25 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63f00d37a20169743d9709977b382c379560ef9e

Related: fdo#51247 bandaid to not crash
Comment 4 Rainer Bielefeld Retired 2012-08-18 06:38:48 UTC
Still [Reproducible] with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit) 

But indeed no longer reproducible  
- with unzipped Master Build  "LOdev " 3.7.0.0.alpha0+  ENGLISH UI  [Build ID: 03d64b7]" (tinderbox:W2008R2@20, pull time 2012-08-18 00:16:52) // WIN7 Home Premium (64bit)

Might be good to have this backported to 3.6, but i think it's not worth bigger efforts because I doubt that many users will be affected.
Comment 5 Not Assigned 2012-10-26 15:45:49 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa06651526d47d9e102fbffc6e3f17da2a7ec160&g=libreoffice-3-6

Related: fdo#51247 bandaid to not crash


It will be available in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2012-10-26 16:04:48 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc7fe4eec579dbb5bf816dfa3fd53f8fec88da7c&g=libreoffice-3-5

Related: fdo#51247 bandaid to not crash


It will be available in LibreOffice 3.5.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.