Bug 51338 - : Make Base the front end for HSQLDB
Summary: : Make Base the front end for HSQLDB
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-22 09:38 UTC by Dan Lewis
Modified: 2013-05-28 17:33 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Lewis 2012-06-22 09:38:12 UTC
Enhancement request

Urgency:
This is a problem that has existed since HSQLDB v. 1.8 was no longer the latest stable version.

Problem description: 
Base has not updated the HSQLDB database engine because the .odb file contains an embedded database. Remove the embedded database files placing them in their separate folder, and Base can connect to them using the latest version of HSQLDB. 
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:
An .odb file contains files in the database folder for embedded databases. It does not contain this folder when it is used to connect to an external database.

Expected behavior:
   When Base creates a new database, a folder should be selected in which to place the database files and the files should be created in this folder. Create the .odb file as you would when connecting to an external database. So, the only new required is selecting a folder for the files and writing them to it.
   When I use Tools > Options > Libreoffice > Java > Class Path to at HSQLDB 2.x, I can connect to a folder containing the database files. So, this can be done with HSQLDB as well.
   The Database Wizard would need to be modified to do two things: select a folder in which to place the database files creating the folder if necessary, write the necessary files in this folder.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120604 Firefox/13.0 SeaMonkey/2.10
Comment 1 Jochen 2012-08-29 18:44:39 UTC
@Robert

Please have a look at this bugerport. What is your opinion?
Comment 2 Dan Lewis 2012-08-29 19:28:24 UTC
I already have taken existing embedded databases and connected them using Base and HSQLDB 2.2.8 using the steps below using health.odb as an example.

1) Extract the database folder from health.odb to ~/.database-hsql/
2) Change the name of the folder to health. 
3) Add health as a prefix to the files in the health folder.(health.data,health.properties, 
   health.script)
4) Tools -> Options -> LibreOffice -> Java -> Class Path: 
   add the location of hsqldb.jar.
   (In my case this is /usr/local/hsqldb-2.2.8/hsqldb/lib/hsqldb.jar)
5) Close LO and reopen.
6) Datasource URL: hsqldb:file:/home/danlewis/.database-hsql/health
   /health;default_schema=true;shutdown=true;hsqldb.default_table_type=cached;
   get_column_name=false
7) Test Class: org.hsqldb.jdbcDriver
Comment 3 Jochen 2012-08-29 19:50:13 UTC
@Rainer,

this bugreport is possibly associated with other bugreports.
Which procedure would you suggest? E.g. "depends on" or "duplicate"?
Comment 4 robert 2012-08-29 20:04:13 UTC
I have added some links to other bugs. There are many ideas to change the internal database, the behaviour of the internal database and so on.

Creating external HSQLDB-databases works already. There are some problems (when external HSQLDB has another version of HSQLDB could be, the you could not open internal databases; Autoincrement-Values are not created right in the GUI ...), but you can create databases in this way now.

The intention of other people is, to make Firebird to the next internal database. This could be a good idea, when we will solve many problems that appear, when using Java and C/C++ parallel.

I don't miss functions in the old HSQLDB. There are more other problems, which could be solved, before a normal user will hit the wall of the old HSQLDB. 

And, what we must also know, the changing of the structure with the internal database will complicate the communication between users, who use OOo/AOO and LO. Databases, created in a newer version of LO would not be readable in OOo/AOO and older LO. So I wouldn't use such a newer version of LO for work, because I have to communicate with many installed Office-Versions, which only work with the old internal HSQLDB.
Comment 5 Jochen 2012-08-29 20:20:16 UTC
(In reply to comment #4)
> And, what we must also know, the changing of the structure with the internal
> database will complicate the communication between users, who use OOo/AOO and
> LO. Databases, created in a newer version of LO would not be readable in
> OOo/AOO and older LO. So I wouldn't use such a newer version of LO for work,
> because I have to communicate with many installed Office-Versions, which only
> work with the old internal HSQLDB.

@Robert
This statement "disappears" in this bugreport. But your statement is IMHO important.
Proposal: create a new bugreport with your statement (and perhaps a thread on the QA-mailinglist). I can do this also after you have created a special bugreport.
Comment 6 Joel Madero 2013-05-28 15:37:35 UTC Comment hidden (obsolete)
Comment 7 Dan Lewis 2013-05-28 17:25:39 UTC
Close this bug since nothing will be done with it anyway. Besides, the trend in Base is to replace HSQLDB with Firebird.
Comment 8 Dan Lewis 2013-05-28 17:31:47 UTC
On 05/28/2013 11:37 AM, bugzilla-daemon@freedesktop.org wrote:
> Joel Madero <mailto:jmadero.dev@gmail.com> changed bug 51338 
> <https://bugs.freedesktop.org/show_bug.cgi?id=51338>
> What 	Removed 	Added
> QA Contact 		qa-admin@libreoffice.org
>
> *Comment # 6 <https://bugs.freedesktop.org/show_bug.cgi?id=51338#c6> 
> on bug 51338 <https://bugs.freedesktop.org/show_bug.cgi?id=51338> from 
> Joel Madero <mailto:jmadero.dev@gmail.com> *
> Dear Bug Submitter,
>
> This bug has been in NEEDINFO status with no change for at least 6 months.
> Please provide the requested information as soon as possible and mark the bug
> as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in
> NEEDINFO status with no change in 30 days the QA team will close the bug as
> INVALID due to lack of needed information.
>
> For more information about our NEEDINFO policy please read the wiki located
> here:
> https://wiki.documentfoundation.org/QA/FDO/NEEDINFO
>
> If you have already provided the requested information, please mark the bug as
> UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.
>
>
> Thank you for helping us make LibreOffice even better for everyone!
>
>
> Warm Regards,
> QA Team
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
      I have requested this bug be closed. (No one was willing to do 
anything about it, and firefox is going to be replacing HSQLDB anyway.) 
Meanwhile I am using Base  as a front end for HSQLDB 2.2.9 so I know it 
can be done without much difficulty other than with the dialog used to 
copy tables from embedded databases to external database files.

--Dan
Comment 9 Joel Madero 2013-05-28 17:33:44 UTC
Thanks Dan, apologies for the delay and thanks for taking the time to update it.

Per request - marking as INVALID to close the bug