Download it now!
Bug 51374 - CONFIGURATION: New Ruler Implementation Doesn't Work for Custom Colours
Summary: CONFIGURATION: New Ruler Implementation Doesn't Work for Custom Colours
Status: RESOLVED DUPLICATE of bug 51534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-24 03:35 UTC by Zeki Bildirici
Modified: 2014-09-04 19:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
New Ruler View in LibreOffice 3.6 Beta2 (126.23 KB, image/png)
2012-07-06 13:38 UTC, Zeki Bildirici
Details
New Ruler View in LibreOffice 3.6 Beta2 with custom colors, extra parts are still visible (128.59 KB, image/png)
2012-07-06 13:40 UTC, Zeki Bildirici
Details
new ruler with custom colors (111.83 KB, image/jpeg)
2012-07-28 13:39 UTC, Zeki Bildirici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2012-06-24 03:35:14 UTC
Problem description: 

The new ruler implementation does not work when custom application colors used for Writer's application background.

This implementation only works with the default color.

http://wiki.documentfoundation.org/ReleaseNotes/3.6#GUI

Steps to reproduce:
1. Change Writers Application Background Colour from 'Tools- Options - Appearance -> Application background'

Current behavior:

The previosly hidden parts of the ruler became visible

Expected behavior:

To have this nice feature with custom colors. (The current colour is too bright for me :))
Comment 1 Florian Reisinger 2012-07-06 08:21:35 UTC
Hm, for me @Ubuntu it seems to be quite the same (LibO 3,6b3 and 3.5.x) Please post a screenshot with the difference ;)
Comment 2 Zeki Bildirici 2012-07-06 13:38:57 UTC
Created attachment 63906 [details]
New Ruler View in LibreOffice 3.6 Beta2

New Ruler View in LibreOffice 3.6 Beta2
Comment 3 Zeki Bildirici 2012-07-06 13:40:06 UTC
Created attachment 63907 [details]
New Ruler View in LibreOffice 3.6 Beta2 with custom colors, extra parts are still visible

New Ruler View in LibreOffice 3.6 Beta2 with custom colors, extra parts are still visible
Comment 4 Zeki Bildirici 2012-07-06 13:41:25 UTC
(In reply to comment #1)
> Hm, for me @Ubuntu it seems to be quite the same (LibO 3,6b3 and 3.5.x) Please
> post a screenshot with the difference ;)

Hi,

I attached the screenshots. Just select the Application Background as Automatic, from Tools-LOWriter-Apperance

Regards,
Zeki
Comment 5 Florian Reisinger 2012-07-06 23:57:55 UTC
Yep I got that and was able to repoduce this, but I need a working screenshot ( How it should look like), because I  can't reproduce it here with LibO 3.5.x
Comment 6 Zeki Bildirici 2012-07-28 13:39:21 UTC
Created attachment 64823 [details]
new ruler with custom colors
Comment 7 Zeki Bildirici 2012-07-28 13:42:20 UTC
I've added the screepshot, which i created with MS Paint :)

It is not an urgent issue, and i dont think too many people preffering different application backgrounds than the default. 

Regards,
Zeki
Comment 8 QA Administrators 2013-05-27 16:54:48 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 9 Florian Reisinger 2013-05-27 17:32:52 UTC
Hmm, I think the status should be NEW, but let stay with NEEDINFO

Can you reproduce it with 4.0 or a master build?
Comment 10 Zeki Bildirici 2013-05-27 19:20:43 UTC
(In reply to comment #9)
> Hmm, I think the status should be NEW, but let stay with NEEDINFO
> 
> Can you reproduce it with 4.0 or a master build?

Yes i can reproduce. Taking this as a enchancement will be better as it is not a bug. Btw Microsof Office 2007 has the same behaviour with LibreOffice for ruler colour(rulers sides has the same colour with background, changing it makes a crappy look), i will check on Microsoft Office 2010.

Best regards,
Zeki
Comment 11 Florian Reisinger 2013-05-28 08:10:53 UTC
Setting status to NEW
Comment 12 Maxim Monastirsky 2014-09-04 19:31:54 UTC

*** This bug has been marked as a duplicate of bug 51534 ***