Bug Hunting Session
Bug 51384 - Search in help crashes LibreOffice
Summary: Search in help crashes LibreOffice
Status: CLOSED DUPLICATE of bug 53337
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-24 11:06 UTC by Leif Lodahl
Modified: 2012-10-24 11:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Lodahl 2012-06-24 11:06:58 UTC
LibreOffice crashes each and every time I search in the help.
Comment 1 Korrawit Pruegsanusak 2012-07-01 04:07:11 UTC
More info please :-)
such as LibO version, OS and version, detailed steps to reproduce, etc.

[NOT REPRODUCIBLE] with master daily build 3.7.0.0.alpha0+, Build ID: ff27d84, tinderbox Linux-Fedora15-x86_64@4-gcc-4.6-dbgutil, pull time 2012-06-25 23:42:59, on Fedora 15 x86_64 with English LOCALHELP installed.

1. open Start Center
2. press <F1>, localhelp appear
3. select tab <Find>
4. typing "search" without quotes, <Enter>
5. result appears and browse-able
Comment 2 Leif Lodahl 2012-07-01 08:29:33 UTC
Sorry,
UBUNTU 12.04 and LibO 3.6.0.0beta2 build ID:f010139
Danish help installed
US English help not installed

I will try to install English help but I'm on vacation now so it might be in couple of days from now.
Comment 3 Korrawit Pruegsanusak 2012-07-04 02:19:23 UTC
(In reply to comment #2)
> UBUNTU 12.04 and LibO 3.6.0.0beta2 build ID:f010139
> Danish help installed
> US English help not installed

Still [NOT REPRODUCIBLE] with the environment described (x64).

Note that I used the packages downloaded from website, and installed in parallel. This means I didn't use ubuntu PPA. What did you use? How did you install (in parallel / normal install)?

Could you describe / explain the exact steps how to reproduce it?

> I will try to install English help but I'm on vacation now so it might be in
> couple of days from now.

If it still crashes in any help languages, please use libreoffice PPA at https://launchpad.net/~libreoffice/+archive/libreoffice-prereleases, install libreoffice-dbg, and follow http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
Comment 4 Harald Koester 2012-07-04 04:36:42 UTC
This problem may be a Java 7 problem. See bug 50371.
Comment 5 Leif Lodahl 2012-07-05 04:15:05 UTC
Hi,
I installed parallel as well using the following script:

---
#!/bin/bash

for i in LibO-Dev_3.6.0.0.beta2_Linux_x86_install-deb_en-US/DEBS/*.deb; do dpkg-deb -x $i . ; done
for i in LibO-Dev_3.6.0.0.beta2_Linux_x86_langpack-deb_da/DEBS/*.deb; do dpkg-deb -x $i . ; done
for i in LibO-Dev_3.6.0.0.beta2_Linux_x86_helppack-deb_da/DEBS/*.deb; do dpkg-deb -x $i . ; done

bash /home/leif/Skrivebord/libreoffice/opt/lodev3.6/program/soffice
---
Comment 6 Leif Lodahl 2012-07-16 15:58:39 UTC
I have made two tests:
Both with the following three packages:
"LibO_3.6.0.1_Linux_x86_helppack-deb_da"
"LibO_3.6.0.1_Linux_x86_install-deb_en-US"
"LibO_3.6.0.1_Linux_x86_langpack-deb_da"

First a regular installation with "sudo dpkg -i *.deb"
Result: No problem. Search works fine
Second a paralel installation with "for i in LibO_3.6.0.1_Linux_x86_install-deb_en-US/DEBS/*.deb; do dpkg-deb -x $i"
Result: LibreOffice closes without error or warning when I search in help.
Comment 7 Julien Nabet 2012-10-18 18:48:02 UTC
Leif: could you clean all your LO install (with purge options) + remove ~/.config/libreoffice and test the package of your distrib or libreoffice ppa? (https://launchpad.net/~libreoffice/+archive/ppa)
Comment 8 Alex Thurgood 2012-10-24 11:24:22 UTC

*** This bug has been marked as a duplicate of bug 53337 ***
Comment 9 Alex Thurgood 2012-10-24 11:24:57 UTC
Slated as fixed in 3.6.2, confirming that it is fixed in 3.6.3 rc1.

Alex