Download it now!
Bug 51427 - "Restore Windows" Dialogue Box Persistant at Startup - Unable to Dismiss
Summary: "Restore Windows" Dialogue Box Persistant at Startup - Unable to Dismiss
Status: RESOLVED DUPLICATE of bug 39007
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Mac OS X (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-25 18:56 UTC by Mark Kirshner
Modified: 2012-06-26 02:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot of persistent dialogue box. (222.71 KB, image/png)
2012-06-25 18:56 UTC, Mark Kirshner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Kirshner 2012-06-25 18:56:44 UTC
Created attachment 63470 [details]
Screen shot of persistent dialogue box.

While editing a text document I quit the editor and/or re-booted (can't recall). 

Now, each and every time i try to start up the suite I get a persistent dialogue box complaining that: "The application "LibreOffice" unexpectedly quit while trying to restore its windows.  Do you want to try to restore its windows again?"

The options are "Restore" and "Don't Restore" no matter which one i select it does not go away and i can't use the product because the dialogue box will not dismiss and the focus of the box is always on top of all LO windows.  
I need to force quit the dialogue box so i can reboot.  

I have completely uninstalled and removed all LO software (several times), installed OpenOffice and get the same LibreOffice dialogue box!

Not sure in which file the OS keeps this error flag so I could clear it.

Any clue would be helpful.

Kind Regards,

Mark

mark.kirshner@gmail.com
1-917-589-3788

Please see attached screen shot.
Comment 1 Roman Eisele 2012-06-26 02:10:13 UTC
Hello Mark Kirshner,

thank you very much for your bug report! I agree with you that this is a critical issue. It is already known, therefore I mark this report as a duplicate of the main bug report for this issue -- bug 39007. In the report for bug 39007 you will find some suggestions how to solve the problem, at least for some time (see comments no. 2, 6, and 20 there). Basically, you need to delete the file
"org.libreoffice.script.savedState"
from the folder
"~/Library/Saved Application State/"
(~ is your user/home folder) and to reboot your Mac.

I hope that our developers will fix this issue soon and for good, but it seems it is not easy to fix, it is some kind of terrible "misunderstanding" between LibreOffice and MacOS X 10.7 (AFAIK 10.7 only).

*** This bug has been marked as a duplicate of bug 39007 ***
Comment 2 Roman Eisele 2012-06-26 02:30:31 UTC
(In reply to comment #1)
> some time (see comments no. 2, 6, and 20 there). Basically, you need to delete
> the file
> "org.libreoffice.script.savedState"
> from the folder
> "~/Library/Saved Application State/"
> (~ is your user/home folder) and to reboot your Mac.

Sorry, I forgot that the ~/Library/ folder is (by default) hidden on MacOS X 10.7 (Lion). Therefore, to access it, select "Go to Folder" from the Finder's "Go" menu and enter "~/Library" (without quotation marks) in the dialog window which appears.