Download it now!
Bug 51525 - UI: For Impress, please add "Paste Unformatted Text" to the commands list in the "Customize > Add Commands" dialog
Summary: UI: For Impress, please add "Paste Unformatted Text" to the commands list in ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: high enhancement
Assignee: Andrzej Hunt
URL:
Whiteboard: target:4.3.0
Keywords:
: 51896 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-28 09:03 UTC by Roman Eisele
Modified: 2014-02-05 21:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Eisele 2012-06-28 09:03:14 UTC
The "Add commands" dialog window, available via "Tools > Customize > Menus" and clicking "Add...", allows to add the command "Paste Unformatted Text" to Writer, but not to Impress (please see the screenshots attachment 63129 [details] and attachment 63130 [details]). This is a little inconsistency, and is obstructive especially for power users. Therefore, please allow us to add "Paste Unformatted Text" to Impress, too.

Notes:
1) The exact way to see the list of commands which I refer to (sorry, very complicated!):
* select "Tools > Customize" from the menu bar;
* the "Customize" dialog window appears;
* select the tab "Menus";
* select "Edit" from the popup menu "Menu";
* select "Impress" from the popup menu "Save In";
* click on the button "Add..."
* the "Add Commands" dialog window appears;
* select "Edit" from the list "Category" (at the left);
* now scroll down the right list:
you will find "Paste" and "Paste Special", but no "Paste Unformatted text".

2) We also can't add "Paste Unformatted Text" to Calc, but this seems to be a bug, because in place of the missing "Paste Unformatted Text" item there is a duplicated "Paste Special" item in the commands list for Calc -- see bug 50746.
Comment 1 Joel Madero 2012-07-09 15:47:44 UTC
I'm going to raise this to a high level enhancement. Reason being:

1. Not that difficult since we already have the code in writer
2. Consistency across software is a must if we want to avoid confusion/irritation

@Roman Eisele -- thanks for the detailed explanation of the problem, it's appreciated by the LO team :)

Also, verified in Linux latest build 3.7.0.0.alpha0 BUILD ID c17027c

Lastly, adding EASYHACK to the whiteboard
Comment 2 Cor Nouws 2012-11-23 22:52:23 UTC
I like the idea
Comment 3 Kumāra 2013-02-27 07:53:33 UTC
*** Bug 51896 has been marked as a duplicate of this bug. ***
Comment 4 Kumāra 2013-02-27 08:04:31 UTC
Although I marked the "bug" I reported as a duplicate of this, the request is slightly different, but definitely related. I fully support the effort to create consistency.

I notice a suspected adverse effect of this lack: After much normal pasting (ie with formatting), I now have presentation files that are full of custom graphic styles which aren't in use. You may check out on your side to see if it's true for you too.
Comment 5 Andrzej Hunt 2014-02-02 19:12:53 UTC
1) is now fixed in a patch awaiting review on gerrit.

2) The duplicate "Paste Special" also fixed & awaiting review: one of them
   is actually an "Insert Contents", although they both seem 

This means that there is still no "Paste Unformatted" in Calc. It's not
entirely clear whether this would count as a bug, since there are already
(A) "Paste only Value"
and
(B) "Paste only Text".

However when testing, (A) only functions when copying numerical cells
(but not time values), and (B) only for text cells (also not for time values,
and also not for numerical values) -- I'm going to investigate this a little
more, but it would probably make sense to have a Paste Unformatted here too.
Comment 6 Kumāra 2014-02-03 06:12:41 UTC
(In reply to comment #5)
> This means that there is still no "Paste Unformatted" in Calc.

Isn't this off topic? Anyway, the feature *is* available in Calc. Mail me privately if you need clarification.
Comment 7 Commit Notification 2014-02-05 21:03:53 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84b4b7b931b194fc4d1980d2fa9c7fd6e0c9134c

fdo#51525 Add Paste Unformatted Text to Impress.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Joel Madero 2014-02-05 21:05:26 UTC
Think we can get this one into 4.2.1? Seems pretty small, unlikely to cause a disaster regression :)