Bug 51663 - LibreOffice quits silently (crashes) on Windows XP at startup with %APPDATA% Folder Redirection enabled since LibreOffice 3.5.0
Summary: LibreOffice quits silently (crashes) on Windows XP at startup with %APPDATA% ...
Status: RESOLVED DUPLICATE of bug 50542
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-02 12:37 UTC by Mihkel Soomere
Modified: 2012-07-05 10:04 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Dependency Walker log for 3.5.4 (10.93 KB, application/x-zip-compressed)
2012-07-02 12:37 UTC, Mihkel Soomere
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Soomere 2012-07-02 12:37:40 UTC
Created attachment 63720 [details]
Dependency Walker log for 3.5.4

We are running a mix of XP and 7. We were upgrading from 3.4.3 to 3.5.4 and LibreOffice broke on XP machines for users with Folder Redirection enabled. It works fine with Windows 7, with or without folder redirection. We normally use transform to disable some features but for this we tested with and without transforms, Active Directory deployment and manual install.

Tested versions:
3.4.3 - OK
3.4.6 - OK
3.5.0 - Broken
3.5.4 - Broken
3.6.0 B2 - Broken

The application starts up on 3.5 (no GUI shows up), memory use grows to about 50MB and it works for ~30-60 seconds with some CPU use and it quits. There is no error in Event Log. It creates this folder path (domain name changed):
"\\domain.com\UserData$\UserProfiles\testuser1\Application Data\LibreOffice\3\user\extensions\bundled"
Pay attention that this is the only folder path in LO profile. There are no other folders or files whatsoever! This is specific to 3.5.4
Then soffice.exe quits without error message.

3.6.0 and 3.5.0 create "extensions.db" and "registry" under "bundled". Bundled has 7 folders (com. extensions) with some files. Otherwise it's the same - soffice quits silently after some time.

Attached is Dependancy Walker log for 3.5.4. Other versions are similar with the same eventual error.
It shows that LO is repeadedly requesting SHGetSpecialFolderPath (%APPDATA% path?). After trying for a while it quits with:
Second chance exception 0xE06D7363 (Microsoft C++ Exception) occurred in "c:\windows\system32\KERNEL32.DLL" at address 0x7C812AFB by thread 1.
Comment 1 int0x13 2012-07-05 10:04:02 UTC

*** This bug has been marked as a duplicate of bug 50542 ***