Download it now!
Bug 51748 - EDITING: Data entered in one table occurs in another table as well
Summary: EDITING: Data entered in one table occurs in another table as well
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-05 03:59 UTC by Seved Torstendahl
Modified: 2013-12-05 16:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of the two tables where a formula entered in table Kalmar appears in table Växjö (112.48 KB, image/jpeg)
2012-07-05 03:59 UTC, Seved Torstendahl
Details
Cell N58 selected. Sum=87.3 at bottom (double value). (41.15 KB, image/jpeg)
2012-07-05 05:43 UTC, Seved Torstendahl
Details
Spreadsheet containing errors (67.50 KB, application/vnd.ms-excel)
2012-11-26 16:27 UTC, Seved Torstendahl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Seved Torstendahl 2012-07-05 03:59:22 UTC
Created attachment 63857 [details]
Screenshots of the two tables where a formula entered in table Kalmar appears in table Växjö

Problem description: 
My daughter uses LibreOffice on my recommendation in her business. Last week she suddenly realized that a spreadsheet she uses daily was behaving strangely. E.g. when clicking on one cell containing 46.3 the Sum= at the bottom displayed 112 (or at least not 46.3). Some empty cells displayed non-zero sums. Data entered in one table appeared also in another table. Unfortunately she tried to correct some errors but things got only worse. A couple of cells (I think four) have references between the tables, something like "25.1-Table1:e44".

Steps to reproduce:
1. ....
2. ....
3. ....
I have no clue right now. I will check if I may give you a copy of the failing file. 

Current behavior:

Expected behavior:

Platform (if different from the browser): 
She is using Windows 7 and I have the same behavior with XP and Vista.
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Comment 1 Seved Torstendahl 2012-07-05 05:43:29 UTC
Created attachment 63859 [details]
Cell N58 selected. Sum=87.3 at bottom (double value).

The error in Sum= occurs in the original file of type .xls, Microsoft Office 2003. When I saved the file as .ods this problem disappeared! 

Unfortunately it is not OK to submit the whole file and when I try to remove some data the same cells in the other table are also deleted which makes it impossible to show the error in a small, insensitive file. I will continue to try and keep just some errors.
Comment 2 Seved Torstendahl 2012-07-05 06:31:54 UTC
The spreadsheet has been developed using Open Office 3.3 with Swedish language pack until recently when we changed to Libre Office 3.5.4 with Swedish texts. It has always been saved in .xls format since it must be readable by some others who use Microsoft Office.
Comment 3 Joel Madero 2012-11-21 21:06:28 UTC
I have to mark this as NEEDINFO as we don't have a test case to check it out. I remember in the past we had a similar (or I think similar) issue but it ended up being corrected either by deleting the user profile up updating LibO. 

If this is still a problem it'd be really useful to get a testcase. If you are uncomfortable putting it online, we can arrange something to keep it confidential (we much prefer having it online so if that's not an issue, please just attach it)

Mark as UNCONFIRMED again if this is still a problem and you can get us some kind of a test case. Thanks!
Comment 4 Seved Torstendahl 2012-11-26 16:27:01 UTC
Created attachment 70600 [details]
Spreadsheet containing errors

I have now prepared a spreadsheet where all data that identified persons are replaced. In this anonymization process I used the sheetname and cell position as text. E.g. ”Kalmar-B24” was entered in cell B24 in sheet Kalmar, and similar for ”Växjö-C58”. When many cells in a column were changed ”Kalmar-L*” was used in column L, et c. Later in the process only the first letter of the name of the sheet was used, e.g. ”K-T5”. 

A lot of cells from Kalmar show up in the Växjö sheet, and vice versa. The Svenljunga sheet has also got many cells populated with info from Kalmar and Växjö but I have not seen any effect in the other direction. All complaints about ”#VALUE!” are consequences from numerical values being destroyed when cell contents have been duplicated from other sheets. 

The symptom that the value in Kalmar-M58 was doubled in the Sum= info at the bottom has disappeared in the anonymization process. 

We have a feeling that it all started when a couple of cross references were added. Kalmar-J90 shall be the sum of cells O50+O61+O65 from sheet Växjö, the formula is there and is correctly summed. Kalmar-J91 also refers to sheet Växjö. The file has always been saved in Microsoft Excel 97/2003 format. When saved in ODF format it seemed that there was no duplication of new data to other sheets. 

I have also built LibreOffice from a source tarball libreoffice-core-3.6.5.2 in a Kubuntu system. This newly built LibreOffice Calc was used here. It is possible for me to check the original spreadsheet but I need some hints on how to start debugging, I would be happy to help you. I am quite experienced, have been programming since 1968 and done a lot of debugging on code from other sources!
Comment 5 Seved Torstendahl 2012-11-26 16:37:20 UTC
Of course we could not let this problem block normal work so the spreadsheet was recreated manually (tedious work that we don't want to repeat!). However, this incident gave me some headache trying to persuade my daughter to stay with LibreOffice! And the fact that all user data is lost when upgrading Libre Office from one version to another is quite annoying.
Comment 6 Joel Madero 2013-05-30 20:42:00 UTC
User data issue was resolved in another bug - you must have upgraded early in the process - I believe at that point version 3.6 was still the "officially recommend version" - not sure about today.

Will look at attachments, thanks for getting them up
Comment 7 Joel Madero 2013-06-28 01:03:24 UTC
So I see what you're saying but it's really hard to confirm where it began - does the same issue happen with ods files? 

I am requesting additional input on this one - clearly a bad bug if it's putting data in that you didn't start with but I'm not sure if we can confirm with what's here 

@Devs- what else can we request where we can actually confirm the bug?
Comment 8 Seved Torstendahl 2013-06-29 14:12:25 UTC
I'm aware of that it is almost impossible to understand what happened. My theory is that the cross reference between tables caused the problem initially. When we saved the spreadsheet in ods format the data leakage stopped, but the tables were already destroyed. 

This problem caused frustration and a lot of work to recreate the damaged tables. But we have continued to use Libre Office and upgraded to new releases as they have appeared, currently version 4.0.2 (I have installed 4.0.3) and I like it. I have also got some grandchildren to use Libre Office for their homework! 

I don' think it is worthwhile to continue investigating this, so I suggest that you close the bug now.
Comment 9 Joel Madero 2013-06-29 15:54:19 UTC
Yeah I suspect without the original document as it was before the save it'll be impossible to track it down.

Thanks for understanding - indeed going to close this one as INVALID just because not enough info to do much about it. Hopefully this never happens to you again.