Bug 51818 - Word count: Numbers should include thousands separator (according to locale)
Summary: Word count: Numbers should include thousands separator (according to locale)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks: Word-Count
  Show dependency treegraph
 
Reported: 2012-07-06 23:49 UTC by Muhammad Haggag
Modified: 2016-10-24 21:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammad Haggag 2012-07-06 23:49:36 UTC
See: https://bugs.freedesktop.org/show_bug.cgi?id=34772#c21

Large numbers (thousands) are hard to read without thousands separators.
Comment 1 Zeki Bildirici 2012-07-28 07:38:48 UTC
(In reply to comment #0)
> See: https://bugs.freedesktop.org/show_bug.cgi?id=34772#c21
> 
> Large numbers (thousands) are hard to read without thousands separators.

Hi,

Thank you for your interest on this matter


>Now the string is actually: "Words: 1000 Selected: 5" so it shouldn't be a
>problem to add separators back.

It is fine :)

Regards,
Zeki
Comment 2 A (Andy) 2013-05-05 13:04:22 UTC
I would agree this would be nice improvement and seems like an Easy Hack.

Steps to Reproduce:
1. Open WRITER
2. Open a larger document or create a new text document with more than 1.000 characters or words
3. Go to the menu TOOLS -> WORD COUNT

Result: The word count shows no thousands separators.

@Muhammad: You have inserted you as "Assigned to".  Is this correct, that you want to take care of it and program a solution?
Comment 3 Muhammad Haggag 2013-05-05 15:35:41 UTC
I worked on it for a bit, but dropped it due to life distractions. I've reverted the assignment so that people can pick it up if they're interested. I'll look into it if I get some time.
Comment 4 A (Andy) 2014-03-15 20:30:43 UTC
This should also be done for FILE -> PROPERTIES -> tab STATISTICS like in TOOLS -> AUTOCORRECT OPTIONS -> tab WORD COMPLETION -> max. entries
Comment 5 Commit Notification 2014-04-07 11:17:57 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eae2e87ba4de1ae59779cbfc56109aa6c27fbc17

Resolves: fdo#51818 format word count numbers with locale rules



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-04-07 12:02:27 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9526d1969da25189563a99476176842d38418b76

Related: fdo#51818 format statistical numbers with locale rules



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Adolfo Jayme 2014-04-07 16:20:53 UTC
Awesome, Caolán! :-)