Bug Hunting Session
Bug 51828 - UI: Sort: can use more than 3 criteria once only
Summary: UI: Sort: can use more than 3 criteria once only
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta3
Hardware: Other All
: medium normal
Assignee: Albert Thuswaldner
URL:
Whiteboard: BSA target:4.1.0 target:4.0.3
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-07 04:33 UTC by pierre-yves samyn
Modified: 2013-07-08 04:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot after step 3 (16.59 KB, image/png)
2012-07-07 04:33 UTC, pierre-yves samyn
Details
Screenshot after step 4 (14.97 KB, image/png)
2012-07-07 04:34 UTC, pierre-yves samyn
Details
Sample document with data for sorting (10.69 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-07-07 04:35 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2012-07-07 04:33:03 UTC
Hello

Steps to reproduce :
1. Open attached document
2. Data> Sort
3. Define more than 3 keys

See screenshot after step 3 (4 sort keys)

4. Ok (close & sort)
5. Data> Sort

Expected result : display the last used criteria, ability to select others
Actual result : display only the first 3 ; no way to add other criterias 

Platform : windows 7 64 bits & Version 3.6.0.0.beta3 (Build ID: 3e2b862)

Regards 
Pierre-Yves
Comment 1 pierre-yves samyn 2012-07-07 04:33:57 UTC
Created attachment 63933 [details]
Screenshot after step 3
Comment 2 pierre-yves samyn 2012-07-07 04:34:27 UTC
Created attachment 63934 [details]
Screenshot after step 4
Comment 3 pierre-yves samyn 2012-07-07 04:35:52 UTC
Created attachment 63935 [details]
Sample document with data for sorting
Comment 4 pierre-yves samyn 2012-07-07 04:38:23 UTC
Sorry mistake in the screenshot name : "Screenshot after step 4" is actually after step 5
Comment 5 Markus Mohrhard 2012-07-13 06:35:17 UTC
Please retest with RC2.

Seems the dialog used in some cases the wrong sort direction while it did not display it.
Comment 6 pierre-yves samyn 2012-07-13 10:14:32 UTC
(In reply to comment #5)
> Please retest with RC2.
> 

RC2 ?  FWIK there's only Version 3.6.0.1 (Build ID: 73f9fb6) today ?

I tried with this version with same result, and I can specify the bug.

1. recall the Sort dialog (step 5) only shows the first three criterias used in previous sorting (expected all used criterias).

2. the only way to add a new criteria is to modify the third (choose the same field is ok). Only this displays the "Sort key 4" zone (listbox, radio buttons)

Regards
Pierre-Yves
Comment 7 pierre-yves samyn 2012-07-17 06:18:24 UTC
Reproduced (fr-discuss) with : Ubuntu 11.10 x86_64 gnome-shell
Version 3.6.0.1+ (Build ID: de9c6a7)
Comment 8 pierre-yves samyn 2012-07-17 09:41:47 UTC
Reproduced (fr-discuss) with : Ubuntu 12.04, LibO 3.6.0.0.beta3 (Build ID: 3e2b862)
Comment 9 Roman Eisele 2012-07-21 13:19:37 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Please retest with RC2.
> > 
> RC2 ?  FWIK there's only Version 3.6.0.1 (Build ID: 73f9fb6) today ?

I don't know what exactly Markus Morhard meant, but if he referred to 3.6 RC 2 = 3.6.0.2 in the new numbering scheme, it is available now. So please retest with this version -- maybe it's fixed ...
Comment 10 pierre-yves samyn 2012-07-22 05:10:28 UTC
Reproduced with Version 3.6.0.2 (Build ID: 815c576) and windows 7 64bits
Comment 11 Albert Thuswaldner 2012-08-13 23:07:46 UTC
Ok, there seams to be two bugs here:

1.) comment #6 Step 2.

It seems that if the option "Range contains column labels" is set, the sort key are selected by default i.e. using the test file Sort.ods we have:

Sort key 1 = NĀ° Client
Sort key 2 = Mois	
Sort key 3 = Client

why do we have this behavior? Is it desired? Toggle the option "Range contains column labels" and see yourself.

When "Range contains column labels" is "off", we normally start with:

Sort key 1 = Column A
Sort key 2 = -undefined-
Sort key 3 = -undefined-

As for now, the trigger for displaying an additional sort key is when selecting a row/column for the currently last sort key. 

Proposed solution: make sure that we always have a last sort key which is -undefined-

2.) Make sure saving the previous used sort criteria beyond sort key 3.
Comment 12 Commit Notification 2013-04-11 13:02:21 UTC
Albert Thuswaldner committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=15e0ef908c9e54527276500cf7a537055c374850

fdo#51828 - UI: Sort: can use more than 3 criteria once only



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2013-04-12 02:12:33 UTC
Albert Thuswaldner committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0ed9aab7615ae471abe1aecc4b7665c45ed85aaf&h=libreoffice-4-0

fdo#51828 - UI: Sort: can use more than 3 criteria once only


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 pierre-yves samyn 2013-04-21 09:18:23 UTC
Hello

Thank you for the patch. It fixes some cases but not all...

Tested with Windows 7 64bits & 
Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39)


A. Not Fixed

1. Open attached document
2. Data> Sort

Expected result : display the last used criteria, ability to select others
Actual result : display only the first 3 ; no way to add other criterias 
(only possible if you modify sort key 3). Same as "Screenshot after step 4".

B. Fixed

1. Open attached document
2. Data> Sort
3. Modifiy Sort key 3 (select "Client" instead of "Mois")

Expected & actual result : "sort key 4 - undefined" added

4. Close with Ok
5. Data> Sort

Expected & actual result : Display the previous three criteria plus a fourth "undefined" sort key 4". This is Ok...

Regards
Pierre-Yves
Comment 15 Commit Notification 2013-05-06 09:48:23 UTC
Albert Thuswaldner committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b9cd66b970a2b76d6f07ead71b9df7a9232ff5af

fdo#51828 - UI: Sort: can use more than 3 criteria once only - additional fix



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2013-05-07 07:19:21 UTC
Albert Thuswaldner committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=104edfdc77147b49f32df55e8b48a3aef4542c87&h=libreoffice-4-0

fdo#51828 - UI: Sort: can use more than 3 criteria once only - additional fix


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 pierre-yves samyn 2013-06-15 05:44:48 UTC
Hello

WORKSFORME on windows 7 64bits and:

Version 4.0.4.1 (Build ID: 7fdd5ee61c1c7379dd088f5d50265f0adbccf53)

Version: 4.1.0.0.beta2+
Build ID: 509fa206b0f612d61740632c59351b69bbcfcad
TinderBox: Win-x86_9-Voreppe, Branch:libreoffice-4-1, Time: 2013-06-13_12:35:41

Thank you :)
Regards
Pierre-Yves
Comment 18 Jean-Baptiste Faure 2013-07-08 04:57:56 UTC
Because there is a patch which fixes this bug, WorksForMe is not appropriate, set to FIXED.

Best regards. JBF