Bug Hunting Session
Bug 51930 - Writer: Word Reversal In Table Cell with vertical text (fix: change column width, and undo)
Summary: Writer: Word Reversal In Table Cell with vertical text (fix: change column wi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 58811 (view as bug list)
Depends on:
Blocks: Vertical-Text
  Show dependency treegraph
 
Reported: 2012-07-09 22:44 UTC by David
Modified: 2019-06-12 12:44 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
File containing the problematic table (21.93 KB, application/vnd.oasis.opendocument.text)
2012-07-09 22:44 UTC, David
Details
Screenshot (23.88 KB, application/save)
2012-07-10 05:11 UTC, Rainer Bielefeld Retired
Details
ólátEl instead of Ellátó, ttosítoBizt instead of Biztosított (21.12 KB, image/png)
2013-02-05 13:06 UTC, László Németh
Details
the problematic dot template (63.50 KB, application/msword)
2013-02-05 13:08 UTC, László Németh
Details
Test for letter and word mixed up in cell while turned by 90° (10.63 KB, application/vnd.oasis.opendocument.text)
2015-09-28 10:47 UTC, Hans-Martin Brückmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2012-07-09 22:44:15 UTC
Created attachment 64050 [details]
File containing the problematic table

In the attached document, there is a problem with one cell of the table.   I'd call this cell A3  (to use spreadsheet terminology).  The text in this cell is "Status Spiritual".

When opening the document, you will find that if you place the cursor between the "A" and "T" in the word "Status"  and then press the spacebar, then the words "Status Spiritual" will separate into this text:  "tus Spiritual Sta".    Very odd.


Then if you press backspace (to remove the space you just created), the text in the cell will become  "Spiritual Status".     (which is a reversal of the original wording)


I also notice that when the text turns into  "tus Spiritual Sta" then if you make the column wider, the text will turn into "Spiritual Sta tus"
Comment 1 Rainer Bielefeld Retired 2012-07-10 05:11:10 UTC
Created attachment 64054 [details]
Screenshot

Effect is reproducible with Server Installation of  "LibreOffice 3.6.0.0.beta3  German UI/Locale [Build-ID: 3e2b862] on German WIN7 Home Premium (64bit), but the question is what that might mean. Damaged document? 

@Reporter: What's the history of that document, is it imported from an other format / software or created from the scratch with LibO?
Comment 2 David 2012-07-20 05:52:54 UTC
As far as I can remember, it was created from scratch with LibO  (well, actually, it would have been created originally with OpenOffice, before LibO came out).

If the document is damaged, is there a way to check for that?   (I guess I'm thinking of something equivalent to checkdisk or fsck)
Comment 3 Urmas 2012-11-22 19:33:57 UTC
Apparently issue is caused by laying out multiline text in a narrow column.
Comment 4 Urmas 2012-12-28 01:11:35 UTC
*** Bug 58811 has been marked as a duplicate of this bug. ***
Comment 5 László Németh 2013-02-05 13:04:16 UTC
I believe, I have found the same problem with a Word dot file (official template of a hospital). The problem (displaying mixed words, eg. “ólátEl” instead of “Ellátó”) can be shown after opening the file in LibreOffice master, too. Screenshot, template file are attached. It is a regression from LibreOffice 3.4 or 3.5 (I will check the precise version number.)
Comment 6 László Németh 2013-02-05 13:06:33 UTC
Created attachment 74243 [details]
ólátEl instead of Ellátó, ttosítoBizt instead of Biztosított
Comment 7 László Németh 2013-02-05 13:08:05 UTC
Created attachment 74244 [details]
the problematic dot template
Comment 8 Rainer Bielefeld Retired 2013-02-05 15:31:52 UTC
@László Németh, please consider:
<http://wiki.documentfoundation.org/BugReport_Details#Version>
If you also did this mistake in other Bugs please undo your Version changes there!
Comment 9 Rainer Bielefeld Retired 2013-02-05 17:11:24 UTC
Comment on attachment 74244 [details]
the problematic dot template

Still worked fine with Server Installation of "LibreOffice 3.3.3  English UI/ German Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit)
Comment 10 László Németh 2013-02-05 18:25:08 UTC
It works well in 3.4.2, but not in 3.5.4.2.

(In reply to comment #8)
@Rainer, thanks for the reverting, too! I stopped after my unconscious modification, but I didn't remember the original version number, also the result of my last week tests, so I wanted to check it again on my test machine. (Also I lost the template file last week, so I was glad to find it on the internet again.)
Comment 11 David 2014-02-24 03:28:45 UTC Comment hidden (no-value)
Comment 12 Björn Michaelsen 2014-03-13 10:32:28 UTC
It seems like there is a new line opening which is not rotated below the rotated text above. So likely the cell gets confused about its orientation. (still reproducable in 4.2.2.1).

Note this does not happen in all cells, most other cells have other styles.

Here is the relevant part of the paragraph autostyle P18:

<style:paragraph-properties
  fo:text-align="center"
  style:justify-single-word="false"/>
<style:text-properties
  fo:color="#ffffff"
  style:font-name="Trebuchet MS"
  fo:font-size="14pt"
  style:text-rotation-angle="90"
  style:text-rotation-scale="line-height"/>
Comment 13 Buovjaga 2015-01-14 08:46:11 UTC
"tus Spiritual Sta" still happening.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: b3b4bbaf6cbd2226b659fea7d6ae473ccf84e9dd
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-12_06:13:44
Comment 14 tommy27 2015-07-02 03:29:23 UTC
Win 8.1 64-bit
still happening in LibO 4.4.3.2 and recent 5.1.0.0alpha daily build.
Comment 15 Timur 2015-07-02 10:07:23 UTC
Problem with attachment 64050 [details] that relates to editing can be reproduced even with OO, so inherited and not a regression.
Other problem with attachment 74244 [details] looks different, it's fileopen regression problem that started in 3.5.x, at least in 3.5.4.2. as written. So, that's another bug.
Both problems still exist in 5.1+.
Comment 16 Hans-Martin Brückmann 2015-09-28 10:47:48 UTC
Created attachment 119095 [details]
Test for letter and word mixed up in cell while turned by 90°

Problem persists even in version 5.0.1.1
Comment 17 QA Administrators 2016-11-08 10:36:50 UTC Comment hidden (obsolete)
Comment 18 David 2016-11-10 14:58:38 UTC
This bug is still present in Windows version 5.2.3.3 (x64).
Comment 19 Timur 2017-08-22 13:36:26 UTC
*** Bug 79473 has been marked as a duplicate of this bug. ***
Comment 20 Timur 2018-06-11 15:11:35 UTC
*** Bug 118114 has been marked as a duplicate of this bug. ***
Comment 21 QA Administrators 2019-06-12 02:58:14 UTC Comment hidden (obsolete)
Comment 22 Timur 2019-06-12 07:13:15 UTC
Seeems already fixed at least in 5.4. Good.
Comment 23 Timur 2019-06-12 12:02:01 UTC
I'm not sure about this bug. This one seems OK but duplicated not. I'll reopen them.
Comment 24 Timur 2019-06-12 12:44:45 UTC
To be clear, both  attachment 64050 [details] and attachment 74243 [details] look OK. 
attachment 119095 [details] is not OK but it's probably Bug 79473.