Bug 51935 - Break Link turn cell into #Ref except first cell
Summary: Break Link turn cell into #Ref except first cell
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks: Calc-Cells
  Show dependency treegraph
 
Reported: 2012-07-10 07:47 UTC by Jaise James
Modified: 2019-07-26 12:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (114.58 KB, image/png)
2012-07-16 07:22 UTC, Jaise James
Details
Test doc (8.85 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-16 04:08 UTC, Jaise James
Details
Test doc (8.50 KB, application/vnd.ms-excel)
2012-10-16 04:09 UTC, Jaise James
Details
Document to test the problem (8.85 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-14 05:00 UTC, Jaise James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaise James 2012-07-10 07:47:38 UTC
Break Link [in edit menu] turn cell into #Ref except first cell.

Expected behavior - Retain the cell values

Step to reproduce

1. copy some cell from any saved spreadsheet.
2. paste special as Link
3. go to edit -> Link -> Break link
4. All cell turned to turned # ref except first cell, irrespective reference file available or not.

So we cannot send the file without link.
Comment 1 Valek Filippov 2012-07-15 03:45:05 UTC
Jaise,
it unref the link for me just fine in 3.6rc1 on linux.
Could you check with this version?
Comment 2 Jaise James 2012-07-16 07:22:04 UTC
Created attachment 64261 [details]
screenshot

screen shot
Comment 3 Jaise James 2012-07-16 07:24:05 UTC
see the screen shot what I am getting in while unlinking cells. it is happening in both Linux & windows versions.
Comment 4 Jaise James 2012-10-16 04:08:03 UTC
Created attachment 68598 [details]
Test doc

Test Doc
Comment 5 Jaise James 2012-10-16 04:09:03 UTC
Created attachment 68599 [details]
Test doc

Test Doc
Comment 6 Jaise James 2012-10-16 04:10:12 UTC
Sample test doc attached
Comment 7 Jaise James 2012-10-16 04:32:51 UTC
Note: While breaking, all data is shown. If double click, data turn to #ref. After breaking all cell show data, but for all cell, cell formula point to the first cell of linked array. & any further operation turn cells into #ref.

Example : E7 to G12 is linked array. After breaking, all cells show the formula ={E7} pointing to first cell of linked array. Any further operation turn cells into #ref.
Comment 8 pasqual milvaques 2013-05-13 13:35:59 UTC
I'm being affected also by this bug.

I'm using 4.0.3 in windows xp, I have seen it happenning also in 3.6.6 in windows xp

regards
Comment 9 Jaise James 2013-05-14 05:00:47 UTC
Created attachment 79280 [details]
Document to test the problem

The problem still exsist for version 4.0.3
Comment 10 ign_christian 2013-05-14 07:29:20 UTC
Confirmed using LO 4.0.3.3 (Win7 Home Premium 32bit)

Break Link function not working as expected
Comment 11 Jaise James 2013-05-29 11:32:08 UTC
Breaks the link between the source file and the current document still not working for libre office 4.2 alpha builb.
Comment 12 ign_christian 2013-05-29 12:35:31 UTC
rechanging Version to: 3.6.2.2 release -> we only set this version with oldest version when such problem known
Comment 13 Commit Notification 2014-12-06 07:05:31 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb38796f83f86e07ea0a0b7030eb86ef228a13f0

that just looks wrong, related fdo#51935

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 QA Administrators 2015-12-20 16:17:25 UTC Comment hidden (obsolete)
Comment 15 pasqual milvaques 2015-12-21 17:45:05 UTC
Retested the issue, it still happens in 5.0.4.2 (tested in Fedora Linux). I have also checked the problem in master, is not solved there also although behaviour has changed slightly: when breaking the link, values remains shown in the windows, they are shown as pointing to ref when you force a page refresh by changing to Sheet2 (for example)

Checked that problem already existed in 3.3 to setting version to "inherited from OOo"
Comment 16 QA Administrators 2017-01-03 19:55:24 UTC Comment hidden (obsolete)
Comment 17 pasqual milvaques 2017-01-04 08:48:13 UTC
The bug is still present in LibreOffice 5.24 both in Linux x86-64 (Fedora) and Windows 10 32 bits.
It retains the same behavior which was reported
Comment 18 Xavier Van Wijmeersch 2017-12-07 17:47:02 UTC
repro with

Version: 6.0.0.0.beta1+
Build ID: b4e51cdaf859dfffee0561c51a72eb5c73ee23f4
CPU threads: 2; OS: Linux 4.9; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:libreoffice-6-0, Time: 2017-12-07_08:34:37
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 19 QA Administrators 2018-12-08 03:47:21 UTC Comment hidden (obsolete)
Comment 20 Jaise James 2019-07-26 12:34:13 UTC
Reproducible in 6.3 rc2

Version: 6.3.0.2 (x86)
Build ID: 728469fa359ba8c83d812146293a0b0aa53945ba
CPU threads: 6; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-IN (en_IN); UI-Language: en-US
Calc: threaded