Bug Hunting Session
Bug 51944 - rename file > quit menu entry was:libroCrash on file > quit
Summary: rename file > quit menu entry was:libroCrash on file > quit
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: highest enhancement
Assignee: Laurent Godard
URL:
Whiteboard: target:3.7.0
Keywords:
: 54394 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-10 13:05 UTC by Laurent Godard
Modified: 2012-09-16 06:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
use case : read the text and click the button (macros must be enabled) (11.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-07-10 13:05 UTC, Laurent Godard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2012-07-10 13:05:29 UTC
Created attachment 64066 [details]
use case : read the text and click the button (macros must be enabled)

test case

- a calc file that launches a macro 
- this macro lauches a writer document with loadComponentFromUrl
- close this new writer document using File > Quit

Libreoffice crashes

if the writer document is closed using the quit icon on the window (red cross), it is ok, no crash experienced
Comment 1 Laurent Godard 2012-07-10 13:24:03 UTC
the quit menu entry is here to quit libreoffice and not the file

--> expected behaviour --> close as invalid

BUT

maybe change this Quit menu entry as "Quit LibreOffice"
Comment 2 Laurent Godard 2012-07-10 13:25:44 UTC
to ask for enhancement regarding the wording of the menu
Comment 3 Laurent Godard 2012-07-10 13:26:49 UTC
file > quit is ambigous.
user may think they quit the file, not libreOffice

--> modifiy the menu entry to "Quit LibreOffice"
Comment 4 Not Assigned 2012-07-13 11:21:08 UTC
Laurent Godard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d2afe08450ad041afa21adf48d6c6d90e8cc4e0

change Exit menu entry to Exit %PRODUCTNAME fdo#51944
Comment 5 Jean-Baptiste Faure 2012-09-16 06:10:33 UTC
*** Bug 54394 has been marked as a duplicate of this bug. ***