Download it now!
Bug 52004 - Mac OSX Installer background images offset on OSX 10.7.x and later
Summary: Mac OSX Installer background images offset on OSX 10.7.x and later
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.0 target:4.1.3 target:4.0.6
Keywords:
: 60540 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2012-07-12 09:33 UTC by Alex Thurgood
Modified: 2014-10-23 08:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of offset background images in installer (70.34 KB, image/png)
2012-07-12 09:33 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2012-07-12 09:33:34 UTC
Created attachment 64137 [details]
screenshot of offset background images in installer

Downloaded 3.5.5 final today.
Opened the DMG.
Background images offset.

Enclosed screenshot.

Mac OSX 10.7.4

Alex
Comment 1 Alex Thurgood 2012-07-12 09:59:15 UTC
The problem is specific to OSX 10.7.4
On my Snow Leopard server, the DMG opens an installer window that matches the size of the background images.

Alex
Comment 2 Roman Eisele 2012-07-15 17:22:04 UTC
(In reply to comment #1)
> The problem is specific to OSX 10.7.4
> On my Snow Leopard server, the DMG opens an installer window that matches the
> size of the background images.

Agree -- on my MacOS X 10.6.8 machine, the background image is well-aligned, so really a issue specific to MacOS X 10.7.x.
Comment 3 Alex Thurgood 2013-06-17 10:11:19 UTC
The issue is also present on OSX 10.8.4, with LO 4.0.3.


Alex
Comment 4 Commit Notification 2013-10-08 11:42:39 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d57ddfabf76521590a709e0169b0ee63539cdfe

fdo#52004 set resolution of .dmg background image to 72DPI



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Andras Timar 2013-10-08 11:44:22 UTC
I set the resolution of background image to 72DPI (it was 90DPI). Now it looks good.
Comment 6 Commit Notification 2013-10-08 12:30:41 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26fcde48b6b403c896b18552343de084bc2184c3&h=libreoffice-4-1

fdo#52004 set resolution of .dmg background image to 72DPI


It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 retired 2013-10-08 13:18:00 UTC
Andras: thanks. the os x installer is in need of some love.

Could you have a look at https://bugs.freedesktop.org/show_bug.cgi?id=60540 as well?
Comment 8 Andras Timar 2013-10-08 16:16:49 UTC
*** Bug 60540 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2013-10-09 13:36:21 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ad69afb5174501685114c0bef39718def01fbcd&h=libreoffice-4-0

fdo#52004 set resolution of .dmg background image to 72DPI


It will be available in LibreOffice 4.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-10-09 13:37:18 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0326b8d262a83998b8f2ad8c4e1bbc20a7371d91&h=libreoffice-4-0-6

fdo#52004 set resolution of .dmg background image to 72DPI


It will be available already in LibreOffice 4.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.