Bug Hunting Session
Bug 52066 - FILEOPEN: RTF file opens with black boxes and wrong spacing
Summary: FILEOPEN: RTF file opens with black boxes and wrong spacing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: BSA target:3.7.0 target:3.6.1 target:...
Keywords: filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2012-07-13 18:41 UTC by kaloramik
Modified: 2015-12-17 12:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF file that opens incorrectly (110.45 KB, text/rtf)
2012-07-13 18:41 UTC, kaloramik
Details
Sample document in AOO 3.4 on MacOS X 10.6.8, page 1-2 (227.66 KB, image/png)
2012-07-17 11:21 UTC, Roman Eisele
Details
Screenshot of page 1 and 2 viewed with MS Office 2010 (146.69 KB, image/png)
2012-07-18 15:56 UTC, Roman Eisele
Details
Screenshot of page 3 viewed with MS Office 2010 (149.88 KB, image/png)
2012-07-18 15:57 UTC, Roman Eisele
Details
rtf file when viewed on TextEdit, Mac, looks normal (67.82 KB, image/png)
2012-07-18 19:36 UTC, kaloramik
Details
rtf file when viewed on TextEdit, Mac, looks normal page 2,3 (56.65 KB, image/png)
2012-07-18 19:36 UTC, kaloramik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaloramik 2012-07-13 18:41:42 UTC
Created attachment 64187 [details]
RTF file that opens incorrectly

Problem description: 

Steps to reproduce:
1. .... Download File Here https://www.box.com/s/0f3f54dad69dbccc075a or see attachment 
2. ....Open File in LibreOffice

Current behavior:
Opens with black boxes at the top, ugly spacing throughout the document

Expected behavior:
Opens normally. Note: Opens normally on OpenOffice.org3.3

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Also tested on Linux SuSE
Comment 1 Urmas 2012-07-14 09:51:35 UTC
So that clown vmiklos cannot grasp the concept of multilingual fonts in DOC/RTF after _more than a year_? Pathetic.

Should we make a fundrasing to buy him a normal office suite so he could practice?
Comment 2 Roman Eisele 2012-07-17 09:38:59 UTC
Thank you very much for your bug report!

More or less REPRODUCIBLE with
* LibreOffice 3.5.5.3 (Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21)
* LibreOffice 3.6.0.1 (Build ID: 73f9fb6)
both with German langpack installed and running on MacOS X 10.6.8 (Intel).

> Opens with black boxes at the top,
To be precise, "at the top" are the boxes only when I view the document with LibO 3.5.5.3; in LibO 3.6.0.1, the boxes appear black (wrong) but are probably placed at the correct position (bottom of first page and end of document).

> ugly spacing throughout the document
We should try to express this more precisely; IMHO the lines of text and objects on page 1 take too much room (more than in MS Office, or whatever application was used to create this form), therefore the final lines of the address data flow to page 2 and three; and again, the table on (original) page 2 takes more room in LibreOffice than probably in the original application, therefore the last lines of (original) page 2 flow to page 5.

So we have mostly two problems here:
(1) a problem with the boxes which appear with black background;
(2) a problem with the total size of lines and tables; probably the tables appear bigger in LibreOffice than in the original application.


@mikchen@live.com:
Thank you again for your bug report! Do you know which application was used to create this form (that would be good to know)?

@Urmas:
> the concept of multilingual fonts in DOC/RTF
IMHO it is not obvious why this is a problem with "multilingual fonts in DOC/RTF". If you happen to know the reason of the problems with this file, could you please state briefly what's wrong here with the handling of multilingual fonts, and why this does lead to the visible problems? Thank you.
Comment 3 Roman Eisele 2012-07-17 11:21:35 UTC
Created attachment 64310 [details]
Sample document in AOO 3.4 on MacOS X 10.6.8, page 1-2

(In reply to comment #0)
> Expected behavior:
> Opens normally. Note: Opens normally on OpenOffice.org3.3

But the spacing is "ungly" and probably wrong in Apache OpenOffice (AOO) 3.4, too; or, if the spacing which AOO shows, is correct, then the spacing in LibreOffice is not that bad, too, and only partially wrong. See the attached screenshot of page 1-2 in AOO.
Comment 4 kaloramik 2012-07-17 19:50:02 UTC
Thanks for the reply Roman. 

Sorry, I'm not sure which program created this. I could try copying it into the TextEdit program and saving again. 

One thing that may be of interest is that I changed the font of the title, and it seemed to remove the boxes (spacing issues in the boxes were still there). I thought it might be a font replacement issue, which is something different I have seen from 3.3 to 3.5.
Comment 5 Roman Eisele 2012-07-18 15:56:02 UTC
Created attachment 64353 [details]
Screenshot of page 1 and 2 viewed with MS Office 2010

(In reply to comment #4)
> Sorry, I'm not sure which program created this.
No problem -- I just asked because there was a chance that you knew it. ;-) So let's assume that the file was probably created with Microsoft Office.

> One thing that may be of interest is that I changed the font of the title, and
> it seemed to remove the boxes (spacing issues in the boxes were still there). I
> thought it might be a font replacement issue,
This is possible; I can't tell.

*

I wondered how this document is _supposed_ to look, and therefore borrowed a Win 7 machine with MS Office 2010. I attach the screenshot of page 1-2 (the image was created from two screenshots, therefore don't care for the strange look of the vertical scrollbar ;-).

IMHO the page layout is strange even in MS Office (see the table reaching from page 1 to 2 and therefore split in the middle of a row!). Maybe I have damaged the formatting of the 1st title line by accident, but this does not explain the layout problems. Whoever created this document obviously did not care for resizing/reflowing text issues (a form used to apply for seminars which cost $500 for 4 days could look a bit more professional ;-).

But this is not our problem. What I want to say is that we should concentrate on fixing the "black boxes" problem and on the inexplicable extra page break before the
    "www.hknc.org             ntthknc@hknc.org"
line; the overall spacing and page layout is IMHO a minor problem, because the page layout is not correct even in MS Office.
Comment 6 Roman Eisele 2012-07-18 15:57:14 UTC
Created attachment 64354 [details]
Screenshot of page 3 viewed with MS Office 2010
Comment 7 Roman Eisele 2012-07-18 17:00:57 UTC
Hello Miklós,

this is the bug report I have mentioned in my mail. Please take a look at it. Thank you very much in advance! Best,

Roman
Comment 8 Michael Meeks 2012-07-18 19:28:21 UTC
add regression, rtf_filter annotations.
Comment 9 kaloramik 2012-07-18 19:36:03 UTC
Created attachment 64359 [details]
rtf file when viewed on TextEdit, Mac, looks normal
Comment 10 kaloramik 2012-07-18 19:36:31 UTC
Created attachment 64360 [details]
rtf file when viewed on TextEdit, Mac, looks normal page 2,3
Comment 11 kaloramik 2012-07-18 19:37:24 UTC
oh wow, looks like MS office still has spacing issues. I attached rtf files using TextEdit on Mac to open, seems to look the best.
Comment 12 Not Assigned 2012-07-19 08:16:56 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=173d769a9d32af83ea75dcf4d23b7663a5f19cb9

fdo#52066 fix RTF import of rectangle shape without text in it
Comment 13 Miklos Vajna 2012-07-19 08:22:30 UTC
Hi kaloramik,

So the biggest problem I see is the black boxes, that should be now fixed in master. I'll request cherry-pick to -3-6 and -3-5 soon. If there are any remaining issues, please let's deal with it in a separate bugreport.

Thanks,

Miklos
Comment 14 Not Assigned 2012-07-19 15:53:08 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c1de6d3d6320f91770967d1b23c8dd57d168fe7&g=libreoffice-3-6

fdo#52066 fix RTF import of rectangle shape without text in it


It will be available in LibreOffice 3.6.1.
Comment 15 Not Assigned 2012-07-19 16:05:24 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8e664a17abac2cad8aae9909dbd8c2da3d8557c&g=libreoffice-3-5

fdo#52066 fix RTF import of rectangle shape without text in it


It will be available in LibreOffice 3.5.6.
Comment 16 kaloramik 2012-07-19 18:48:46 UTC
Cool! Thanks!
Comment 17 Roman Eisele 2012-07-20 06:58:16 UTC
(In reply to comment #15)
> Miklos Vajna committed a patch related to this issue.
> It has been pushed to "libreoffice-3-5": [...]
> It will be available in LibreOffice 3.5.6.

Wow -- this was a fast fix! Thank you very much, Miklos! And thank you even more for pushing it also to both 3.6 and 3.5 branches!
Comment 18 Roman Eisele 2012-08-17 09:11:10 UTC
(In reply to comment #13)
> So the biggest problem I see is the black boxes, that should be now fixed in
> master. I'll request cherry-pick to -3-6 and -3-5 soon.

VERIFIED FIXED with LibreOffice 3.6.1.1 (Build ID: 4db6344) on MacOS X 10.6.8 (Intel): no black boxes anymore. Thank you again!
Comment 19 Robinson Tryon (qubit) 2015-12-17 12:07:06 UTC Comment hidden (obsolete)