Download it now!
Bug 52103 - FILEOPEN: DOC Import filter not properly dealing with a) borders b) text box c) tables
Summary: FILEOPEN: DOC Import filter not properly dealing with a) borders b) text box...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-14 22:36 UTC by Sergejs Ušakovs
Modified: 2015-06-12 08:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Attached is B2veidlapa.doc file with tested template, and screenshots from LOO 3.5.5 and MSO2007 (975.76 KB, application/zip)
2012-07-14 22:36 UTC, Sergejs Ušakovs
Details
Screenshot with LOO 3.6.0.1 of pages 1-2 with remarks (281.14 KB, image/jpeg)
2012-07-15 02:26 UTC, Sergejs Ušakovs
Details
B2.veidlapa saved in Word 2010 as DOC (142.00 KB, application/msword)
2014-10-29 16:21 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergejs Ušakovs 2012-07-14 22:36:38 UTC
Created attachment 64223 [details]
Attached is B2veidlapa.doc file with tested template, and screenshots from LOO 3.5.5 and MSO2007

Problem description on imprt of 6 pages .doc template, there are screenshots from both LO 3.5.5 and MSO2007: 
a) HORIZONTAL inner tables border lines are not thin, but as thick as outer border lines: not all occasion, in similar situation soem imported correctly 9 no such issue about VERTICAL inner borders):

On the screenshot of pages 1-2:
those inner borderlines, that are imported WRONGLY  marked with RED cross,
those inner boderlines, that are imported cORRECTLY marked with BLUE cross

b) text box in the bottom of the page where the page Nrt. is supposed to be filled in:
1. misplaced
2. border is to big vs. the text box where to enter a page Nr.
3 the word "lapa"(=page) is misplaced too

marked with GREEN colour on screenshots

c)on the page 3 very defect of import; was generated few line sof empty space, although no such spacing in teh original file - marked on screenshot with PINK colour. 

Actually, this is a greta improvment from previous LOO versions! I used same template for benachmarking.
Steps to reproduce:
1. open B2.doc from attched zip file in LOO 3.5.5
2. open B2.doc in MSO 2007
3. observe difference liek above

Current behavior:
as described, see screenshot from LO 3.5.5

Expected behavior:
as described, see screenshot from MSO2007

Platform (if different from the browser): Win XP SP3
              
Browser: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11
Comment 1 Valek Filippov 2012-07-15 00:57:34 UTC
Sveiki Sergejs,

1. Probably you forgot to save a version of screenshot with crosses on thick lines. Anyway lines looks +/- ok in 3.6rc1 for me.
2. "lapa" is placed properly in 3.6rc1. On the 1st page it's not wrong vertical position, but rather table is shifted down. It looks like LO Writer adds some space on the top for non-existing 'header'. If you switch off header it would be rendered properly ("Page->Header->Header on" checkbox).
3. Fully agree about page 3 mistake. Injection of those lines shifts everything else down and corrupt tables.

Could you please verify with 3.6 RC1 on your system?

Also, try to play with 'Anti-aliasing' and 'HW acceleration' checkboxes ("Tools->Options->View", NE part of the window)
Comment 2 Sergejs Ušakovs 2012-07-15 02:26:07 UTC
Created attachment 64225 [details]
Screenshot with LOO 3.6.0.1 of pages 1-2 with remarks
Comment 3 Sergejs Ušakovs 2012-07-15 02:26:40 UTC
Privet, Valek,

I have tested now with LO 3.6 RC1.
I have made a screenshot of p.1-2 and attached it here.

1) I switched anti-aliasing off, it had some positive effect on inner borders:
first, those inner borders that seemed to be imported too thick - also they still stay mostly too thick vs. what they have to be, they are now 2X as thinner, and thus not anymore of the same thickness as outer border.
second, one more inner border item is imported correctly
third, border of text box for page Nr. in the footer is not thick anymore, but appropriately thin as it had to be.
On the screenshot RED marked are inner borders with WRONG thickness,
BLUE colored with CORRECT thickness.

2) I switched header off, that indeed effected whole table on 1st page shifted up.

Yes, "lapa" is place correctly, but only at vertical ruler.
As for horizontal ruler "lapa" still, as it was previously misplaced few cm-s to the left. I put added "lapa" in pink colour to reflect the correct positions on horizontal ruler.

4) a)The border in the footer seems to be too large and beyond Footer area.

b) But text box for page nr. seems to eb too small vs. its size in MSO2007.
Comment 4 Sergejs Ušakovs 2012-07-15 02:35:29 UTC
Actually on import there was generated some "unnecessary header" on the page 1, that is bug itself - similar to injection few lines on the pages 3 , as already discussed.

Yes, switching header off , of course, helps, but this action means deleting that  header, that is redundant there.
Comment 5 Valek Filippov 2012-07-15 02:47:27 UTC
Interesting... 'lapa" is ok here -- right of the square.

I agree about header, just mentioned to check it.
Comment 6 Sergejs Ušakovs 2012-07-16 23:00:23 UTC
If you see something different as not misplaced "lapa", and not on the same platform as me - Win (XP SP3), may part of the problem be platform-specific?

Actually, currently LOO is very close with DOC import filter to be fully OK with tables/frames, it is almost there.

If such templates can be imported without need for re-adjustment, it surely will improve adoption rates by e.g. state authorities and alike, who are heavy users of such templates, and import artefacts were the deterrents.
Comment 7 Sergejs Ušakovs 2012-07-17 20:45:33 UTC
In respect that in the footer 'lapa" is not misplaced as far as I see, that in 3.5.5.3 it NOT misplaced, but in 3.6.0.1 IS misplaced as I reported above.
Comment 8 Teo91 2013-09-30 13:49:56 UTC
The overall import with LO 4.1.1 on Windows 7 SP1 is good:
- borders witdh now seems ok
- "lapa" is placed correctly

But:
- on page 3 there are still few lines with empty space
Comment 9 Timur 2014-10-29 16:21:28 UTC
Created attachment 108639 [details]
B2.veidlapa saved in Word 2010 as DOC

In LO 4.2.7 and 4.4.0 master, on page 3 there are still 6 additional rows (1 grey and 5 empty), which seems to be the only remaining issue.

Problem with doc import seems to come from the merged sections  "Informācija par izpildinstitūcijas locekli" and "Pases dati". 

But, the same original document, saved again in Word 2010 as doc or docx, opens properly in LO. 
I suggest this be closed as "NotOurBug".