Bug Hunting Session
Bug 52106 - LO consume 100% CPU when loading a document with huge tables using Font not installed in the system
Summary: LO consume 100% CPU when loading a document with huge tables using Font not i...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2012-07-14 23:11 UTC by Maximiliano Castañón
Modified: 2015-12-15 11:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODS file (36.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-14 07:04 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maximiliano Castañón 2012-07-14 23:11:39 UTC
When this document it is in use Libreofice 3.6 b3 start to consume lot of CPU....
even with Apache OpenOffice, 

Reported it on other bug report, but the document when are opened use lot of CPU, 100%
https://bugs.kde.org/show_bug.cgi?id=302614

This is the file, with russian characters...
https://bugs.kde.org/attachment.cgi?id=72160

It consume 70 to 100% CPU... all the time
Comment 1 Valek Filippov 2012-07-14 23:57:28 UTC
It opens in reasonable time here (linux, 3.6rc1).

Scrolling of the loaded document is pretty low, but if you select it all and replace "GOST" font with something installed in your system (eg. FreeSans), then everything works reasonable after that.
Comment 2 Valek Filippov 2012-07-14 23:58:41 UTC
I think it should be "enhancement" not "major".
Comment 3 Maximiliano Castañón 2012-07-15 00:31:12 UTC
Well, at least in the LO3.6 b3 even when changing the font to Liberation serif or sans it still use 100% of CPU, going to try with LO 3.6 RC
Comment 4 Rainer Bielefeld Retired 2012-07-15 05:42:57 UTC
NOT reproducible with reporter's sample and "LibreOffice  3.5.5.3.  German UI/Locale [Build-ID: 7122e39-92ed229-498d286-15e43b4-d70da21] on German WIN7 Home Premium (64bit). It seems that for may be 1 minute after having opened scrolling is a little jerky, but then everything works fine.

Same good result  with with Server Installation of  "LibreOffice 3.6.0.1 rc  German UI/Locale [Build-ID: 73f9fb6] on German WIN7 Home Premium (64bit) 

I read in Valek's Comment 1 that replacing Font "Ghost" improves handling, I can't confirm that for WIN.

@Valek:
I agree with you opinion that this looks like an enhancement request concerning performance as long as we do not have indications for a "real" bug. 

@Maximiliano Castañón:
Please describe you problem more precisely. In the Subject you write "when loading", what seems to say that you have difficulties to open the document. In the report you say simply having document opened costs nearby 100% CPU load.
Please:
- Write a meaningful Summary describing exactly what the problem is
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version (with Build ID if it's not a public release)
     and localization (UI language, Locale setting) where you observed the
     problem the first time
  –- Libo settings that might be related to your problems 
    (Auto-spellcheck? video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an AOOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts
Comment 5 Maximiliano Castañón 2012-07-16 00:17:32 UTC
Hi guys, sorry for my bad description, I'm native spanish, well:

GNU/Linux Debian Unstable

LO 3.6 b3
LO 3.6 rc1

AMD RS780 AMD ATI Radeon HD3200
AMD Athlon X2 2.1GHZ

as you said I can confirm that the 100% CPU usage it's around 60 to 100% usage, after a while (1 or 2 minutes) it down to 10% usage...

There is no spellcheck on it.

I have it set at Spanish.

Well, the unexpected problem is why it consume lot of CPU if it is doing anything, not checking text, and if i have set it at liberation sans why it still using lot of CPU, why it is using CPU if it's using a know font?

Thanks guys.
Comment 6 Rainer Bielefeld Retired 2012-07-16 07:59:39 UTC
Currently no bigger problems reproducible.
Comment 7 Thomas Hackert 2012-07-29 17:16:12 UTC
Hello Maximiliano, *,
(In reply to comment #5)
> GNU/Linux Debian Unstable

I tested it with Debian Testing AMD64 and ... 
> LO 3.6 b3
> LO 3.6 rc1

... LO 3.6. rc2, but cannot reproduce your bug, sorry ... :(

> AMD RS780 AMD ATI Radeon HD3200

NVIdia GeForce 6150+ Chip.

> AMD Athlon X2 2.1GHZ

AMD Athlon X2 6000+ 2x3.0GHz.

> as you said I can confirm that the 100% CPU usage it's around 60 to 100% usage,
> after a while (1 or 2 minutes) it down to 10% usage...

Which java version are you using? Mine is
<quote>
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.3) (6b24-1.11.3-2)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
</quote>

<snip> 
> Well, the unexpected problem is why it consume lot of CPU if it is doing
> anything, not checking text, and if i have set it at liberation sans why it
> still using lot of CPU, why it is using CPU if it's using a know font?

Have you changed something under "Tool - Options - LibreOffice - Memory" or have you changed "Tools - Options - LibreOffice - View; Graphics output" by any chance?
HTH
Thomas.
Comment 8 Maximiliano Castañón 2012-07-31 03:58:59 UTC
Hi, actually I have JAVA disabled, the options on memory tab are the described in the image http://subir.inodochile.net/images/1343707047.png

When I start JAVA i get a message:

Warning: failed to read path from javaldx
Comment 9 Thomas Hackert 2012-09-02 13:57:18 UTC
Hello Maximiliano, *,
(In reply to comment #8)
> Hi, actually I have JAVA disabled, the options on memory tab are the described
> in the image http://subir.inodochile.net/images/1343707047.png

I can neither read nor understand Spanish, sorry ... :( But it seems, that the only options, we have in common, are the time (Eliminar de la memoria...) and the number of objects ... ;) It would be nice, if you could switch the UI language to English the next time, so that we QA guys and gals are able to understand, what you are talking about ... ;)

> When I start JAVA i get a message:
> 
> Warning: failed to read path from javaldx

Oh, you should find many information about this error message, if you enter your distribution with its version/architecture and this error message in a search engine of your choice ... ;) I have found it in the past, when I got it ... ;)
HTH
Thomas.
Comment 10 Maximiliano Castañón 2012-09-02 20:09:14 UTC
Ok, Well, actually it kept using the 90% of CPU longer than 1 minute... using the LO 3.6.0.4 Going to install the last on 3.6.1 and i will provide more info about the CPU usage hahaha
Comment 11 Maximiliano Castañón 2012-09-02 21:10:58 UTC
Thomas, you are right, well, here is the screenshoot in english

http://subir.inodochile.net/images/1346620212.png
Comment 12 Matthias Wieser 2013-05-11 21:32:32 UTC
Hi,

can you try to check, if the problem is present in LO 4?
I opened the file, but the CPU usage was normal, scrolling is slow, but not causing high CPU usage.

Thank you, Matthias
Comment 13 Maximiliano Castañón 2013-05-13 00:04:21 UTC
Hi Mat(In reply to comment #12)
> Hi,
> 
> can you try to check, if the problem is present in LO 4?
> I opened the file, but the CPU usage was normal, scrolling is slow, but not
> causing high CPU usage.
> 
> Thank you, Matthias

Hi, 

after 3 minutoes it's still using 99% of CPU, using LO4.0.3.1

Thanks.
Comment 14 ign_christian 2013-05-14 07:04:25 UTC
Created attachment 79283 [details]
Sample ODS file

Using LO 4.0.3.3 (Win7 Home Premium 32bit) I've experienced relatively normal opening the attached file. 

But I found something abnormal while opening ODS file from Bug 54919 (I reattach that file here) -> took a very long time (very high cpu usage) to open
Comment 15 Joel Madero 2013-06-24 17:19:26 UTC
With the sample document provided by original reporter I cannot reproduce - the document opens quite fast (<10 seconds), no huge spike in CPU.

Marking as WFM - 

With Comment 14 I suggest opening a new bug report to not mix things up (and only if the behavior is confirmed on 4.1 RC :)


Bodhi Linux
LibreOffice Version 4.2 master
Comment 16 Maximiliano Castañón 2013-06-24 21:08:21 UTC
(In reply to comment #15)
> With the sample document provided by original reporter I cannot reproduce -
> the document opens quite fast (<10 seconds), no huge spike in CPU.
> 
> Marking as WFM - 
> 
> With Comment 14 I suggest opening a new bug report to not mix things up (and
> only if the behavior is confirmed on 4.1 RC :)
> 
> 
> Bodhi Linux
> LibreOffice Version 4.2 master

Where can I get the LO 4.2 package?
Comment 17 Joel Madero 2013-06-24 21:44:09 UTC
It's only a master build right now, not recommended at all for daily use. If you want to test it just once (again this is not recommended to keep as it's not stable)

http://dev-builds.libreoffice.org/daily/master/
Comment 18 Robinson Tryon (qubit) 2015-12-15 11:05:11 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]