Bug Hunting Session
Bug 52207 - UI:the navigator is missing several labels
Summary: UI:the navigator is missing several labels
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-17 15:56 UTC by Jean-Baptiste Faure
Modified: 2012-07-18 14:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of navigator in Calc (100.36 KB, image/png)
2012-07-17 15:56 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2012-07-17 15:56:36 UTC
Created attachment 64324 [details]
screenshot of navigator in Calc

Step to reproduce:
open a new spreadsheet in master, clic F5 to open the Navigator.
Several item following icons are missing: linked area, graphics, OLE objects, comments, drawing objects.

Version 3.7.0.0.alpha0+ (Build ID: b480f91)

Best regards. JBF
Comment 1 Not Assigned 2012-07-18 13:39:00 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc05a825e71316e6f602e5c8dfcd3d10ecb6252f

Revert "hrc cleanup: Remove unused Strings in sc", fdo#52207
Comment 2 Markus Mohrhard 2012-07-18 13:50:12 UTC
Problem introduced by another automatic cleanup without testing that this is really correct. Not every ID that is not directly used in the code is really unused. Often in the code we are using them indirectly through a generating method.

I'll write a mail to the dev list to prevent such problems in the future.
Comment 3 Markus Mohrhard 2012-07-18 13:52:01 UTC
There are even more commits from Thomas Arnold that look totally wrong in sc alone. I don't want to know how much more problems are there in the code base by his automatic cleanup. This looks like a source for much more pain. To be honest I fear we need to check all his commits to resource files otherwise we'll have a totally broken UI in 3.7
Comment 4 Jean-Baptiste Faure 2012-07-18 14:24:23 UTC
Verified in Version 3.7.0.0.alpha0+ (Build ID: dc05a82)

Thank you Markus.
Will be difficult to verify the whole UI :-(

Best regards. JBF