Download it now!
Bug 52239 - EDITING , trouble selecting cells with keyboard in calc
Summary: EDITING , trouble selecting cells with keyboard in calc
Status: RESOLVED DUPLICATE of bug 37230
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-18 17:15 UTC by merkursports
Modified: 2013-07-31 23:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A cell outside of an area is trying to be copied taking neighbor cells like reference (319.06 KB, image/jpeg)
2012-07-18 17:15 UTC, merkursports
Details

Note You need to log in before you can comment on or make changes to this bug.
Description merkursports 2012-07-18 17:15:20 UTC
Created attachment 64356 [details]
A cell outside of an area is trying to be copied taking neighbor cells like reference

I have found troubles selecting an area with keyboard. It is not a problem when you are within an area. The trouble is when you begin in a cell outside any area and try to select a neighbor area using shift+ctrl+arrow to go to the end of the block.

Expected behaviour:
using shift+ctrl+arrow should have to stop at last filled cell

Current behaviour
using shift+ctrl+arrow it stops at the end of the spreadsheet, either x or y axis.
Comment 1 merkursports 2012-07-18 17:22:49 UTC
Path to reproduce 

In the picture shown a cell trying to be copied cells under, by example, taking like reference a neighbor column.

Go to cell, Ctrl+C to copy. To extend this copy Shift+left arrow goes one cell left, then to go and select untill to last cell in this column shift+ctrl+down arrow.

It should have to stop at last filled cell, but it goes untill the end of spreadsheet.

When you are within any area and press shift+ctrl+down arrow it stops at the end of the column, (last filled cell)
Comment 2 tmacalp 2013-04-09 20:01:16 UTC
I just found this bug, but appears to be the same as Bug 61534.

From what I can tell, the problem is with with "selection modifying keyboard actions" no longer changing your cursor cell.  These actions include shift+arrow keys, shift+ctrl+arrow keys, etc...

You can easily test for this change by opening a blank spreadsheet, holding shift, and pressing right arrow.  In OpenOffice and previous LO versions, shift + right arrow would extend the selection AND change the cursor cell in the new direction.  Now, it only extends the selection and leaves your cursor cell where it was.

The problem is that ALL actions are based off of your cursor cell, so if you start in a blank column, shift-arrow to select some actual data, and then ctrl-shift-down, it will attempt to go to the bottom of the range, except that the action is still based off of the cursor cell, which is still in a blank column, so it goes to the very bottom of the range.

In bug 61534 there are many examples which explain this behavior. In my opinion, this is a serious regression, as it makes it very difficult for me to select a blank cell range parallel to a filled one.  It also has the possibility of destroying previously recorded macros.

I just don't know if this behavior was intentionally changed or if it is a regression.  Does Excel behave this way?  I don't have access to a current version to a current version of MS Office to compare. If it was intentional, I would love to have a toggle to enable to original (correct) behavior.

I can also verify that this is still affecting LibreOffice 4.0.2.2, both MS Windows and Linux.
Comment 3 crxssi 2013-07-31 23:39:36 UTC

*** This bug has been marked as a duplicate of bug 37230 ***