Download it now!
Bug 52241 - Numbered bibliographies no longer work with more than a few entries
Summary: Numbered bibliographies no longer work with more than a few entries
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: David Tardon
URL:
Whiteboard: target:3.7.0 target:3.6.1 target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-18 17:27 UTC by miker169
Modified: 2012-07-20 05:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document for Bibliography entry numbering issue in 3.6 RC 1 (13.88 KB, application/vnd.oasis.opendocument.text)
2012-07-18 17:27 UTC, miker169
Details

Note You need to log in before you can comment on or make changes to this bug.
Description miker169 2012-07-18 17:27:34 UTC
Created attachment 64358 [details]
Test document for Bibliography entry numbering issue in 3.6 RC 1

Creating a bibliography with number entries like [1], [2], [3] etc. and with more than a few entries is no longer possible 

Normally the bibliography table is organised in the order in which the
references appear in the document, but with 3.6 it seems they are in the
order in which they were created. Also the first reference and the tenth onwards are shown as [0].

Steps to reproduce:

1. Open the attached file in LoDev 3.6RC1
2. Right click the Bibliography then Update Index/Table
3. The reference numbers are scrambled
4. Open the attached file in LibO 3.5.5
5. Right click the Bibliography then Update Index/Table
6. The reference numbers are correctly sorted

I also mentioned this here https://bugs.freedesktop.org/show_bug.cgi?id=49709 as I thought it might be related.

I have marked this "Major" as it is a major regression since 3.5.5. For me it is a show stopper.
Comment 1 David Tardon 2012-07-19 11:59:59 UTC
got it: STL conversion bug
Comment 2 Not Assigned 2012-07-19 12:05:59 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=859018061956b1937c7be3809a9858cbd610fa9c

fdo#52241 remove just one entry
Comment 3 Not Assigned 2012-07-19 12:55:03 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48d61f4ad1eb4f8a031e65c3fcbebc5023d600e9&g=libreoffice-3-6

fdo#52241 remove just one entry


It will be available in LibreOffice 3.6.1.
Comment 4 Eike Rathke 2012-07-19 20:53:59 UTC
Bah, BugZilla was temporarily down when the commit happened so this wasn't automatically added:

Pushed to 3-6-0 with

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-6-0&id=a2267b5d7acc41cea094fe3b86d124540205446a

and should be available in 3.6.0.2rc
Comment 5 David Tardon 2012-07-20 05:26:38 UTC
(In reply to comment #4)
> Bah, BugZilla was temporarily down when the commit happened so this wasn't
> automatically added:
> 
> Pushed to 3-6-0 with
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-6-0&id=a2267b5d7acc41cea094fe3b86d124540205446a
> 
> and should be available in 3.6.0.2rc

3.6.0 rc2 has already been done and should be announced soon. But it will be in 3.6.0 rc3 (the following week).