Bug 52284 - CRASH running particular wizards
Summary: CRASH running particular wizards
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-20 02:43 UTC by Alien
Modified: 2013-01-19 14:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
most recent error log (31.96 KB, text/plain)
2012-07-20 16:06 UTC, Alien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alien 2012-07-20 02:43:26 UTC
Problem description: 
Running most (but not all) wizards kills all LO windows, without any error message - just a brief pause of maybe 1-3 seconds, then all LO windows disappear, as if the process had been killed in Task Manager.

Writer : File -> wizards - brief pause, then crashes / closes
Letter
Fax

Writer : File -> wizards - slightly delayed crash:
Agenda - briefly displays some sort of document, sized so the whole page is visible, seems to be just about finished rendering the window with that document then as with other wizards it crashes / closes.
Web page - opens new window, shows toolbars / status bar, but no document - then crashes / closes.

Writer : File -> wizards - seems to work properly:
Presentation
Document Converter, Euro Converter, Address Data Source: didn't follow them all the way through, but they seemed ok, & they didn't kill LO.

Calc - function wizard: seems ok

Base wizards:
Tables -> Use Wizard To Create Table - brief pause, then crashes / closes.
Queries -> Use Wizard To Create Query - brief pause, then crashes / closes.
Forms -> Use Wizard To Create Form - opens new window, shows toolbars & some other stuff [gone too quick to properly see what], then crashes / closes.
Reports -> Use Wizard To Create Report: opens new window, shows toolbars / status bar, & what looks like a blank document - then crashes / closes.


Current behavior: as described above

Expected behavior: wizards doing what they're supposed to & not killing all open LO windows.

Platform: WinXP (64 bit) SP2. Tried JRE 1.6.0_22, & 1.7.0_02 - doesn't make any difference. This is the first time I've tried running any of the non-Base wizards, but the Base wizards have NEVER worked for me - not in LO, not even with OOo before the LO / OOo split.

Browser: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Comment 1 Rainer Bielefeld Retired 2012-07-20 04:22:08 UTC
NOT reproducible with "LibreOffice  3.5.5.3.  German UI/Locale [Build-ID: 7122e39-92ed229-498d286-15e43b4-d70da21] on German WIN7 Home Premium (64bit)
Comment 2 billhook 2012-07-20 05:21:55 UTC
Not reproducible on 3.5.5.3 on Vista Business SP1 (32bit)
Comment 3 Alien 2012-07-20 15:03:47 UTC
I uninstalled old versions of Java [I had 32 & 64 bit versions of 1.6.0_22, & 1.7.0_02], & installed just the 32 bit version of 1.7.0_05. No improvement though, still crashes.

Is there some sort of diagnostic procedure I should be following, perhaps some way to get it to produce a log file of what's actually going wrong?
Comment 4 Alien 2012-07-20 16:06:42 UTC
Created attachment 64454 [details]
most recent error log

Found the debug parameters for the JRE in the help, & restarted LO, then tried the Letter wizard. Instead of just closing it completely froze, & I had to kill it with Task Manager. Managed to find a bunch of error logs going back to when I updated LO a couple of days ago. I've attached the most recent 1.
Comment 5 Julien Nabet 2012-07-20 20:46:04 UTC
Could it be a dup of fdo#52122 ?
Could you try with a brand new LO profile ? (see http://wiki.documentfoundation.org/UserProfile)
Comment 6 Alien 2012-07-21 23:38:22 UTC
(In reply to comment #5)
> Could it be a dup of fdo#52122 ?
> Could you try with a brand new LO profile ? (see
> http://wiki.documentfoundation.org/UserProfile)

Similar, perhaps, but I don't think it's a dupe. I have no problem viewing the MediaWiki tab, & that hex string mentioned on the other bug is identical between the files from old crash-prone profile, & the file from the newly generated non-chrashy [so far] profile.

As I had a working profile, I made a backup of it & started copying files over from the old to the new profile, & kept trying the wizards to see if what I'd copied / replaced would break the wizards again. I admit it's not a perfect methodology, but I really don't want to have to re-customise everything again from scratch.

I think I've narrowed down the list of suspects to just registrymodifications.xcu.

I haven't yet managed to figure out what part of the crashy version of it is to blame though, which is annoying, as it appears to be the repository of a bunch of my customisation settings. I think I'm going to try manually putting together a new version of the file with stuff manually extracted from a copy of the crashy version, added to a copy of the working version. If that works maybe what's left-over in the copy of the crashy version will provide a clue as to the actual problem.

  ******

And now for something slightly off-topic:

Condensed XML - no indenting is 1 thing, but no *line breaks*? Thankfully PSPad has a function for solving both problems in 1 go.
Comment 7 Alien 2012-07-25 09:55:06 UTC
Well, I faffed around with that .xcu file for a while, before realising that it would be quicker to make a note of my settings, wipe my user profile again, then redo the settings a few at a time until I found the problem.

Of course, I didn't *know* that this would uncover the problem - there could have been some garbled data in the .xcu that I'd missed while skimming through it, but it turns out it was the right call - though I'm surprised at the result.

If I change
Tools -> Options -> LibreOffice -> View -> icon style
to *anything* other than Automatic (Tango) I get the crashes described in my first post. I even tried selecting Tango manually, and it still crashes. And in case anyone's wondering, yes I did try restarting LO after changing icon style, before trying to run a wizard.

It's rather annoying, as I prefer Galaxy. I can still use Galaxy if I don't need to use 1 of the affected wizards, I just have to remember to change it back & restart LO if I need to use 1 of them.
Comment 8 Rainer Bielefeld Retired 2012-07-25 17:31:27 UTC
@Alien
Did that problem appear immediately after an update?
All facts seem to show that this is an other "problems with existing profile after update " problem
Comment 9 Alien 2012-07-25 18:15:31 UTC
(In reply to comment #8)
> @Alien
> Did that problem appear immediately after an update?
> All facts seem to show that this is an other "problems with existing profile
> after update " problem

I deleted the profile [the User folder] as per the instructions on the wiki & let it create a new 1, so I don't think so. The only thing I haven't tried is a complete uninstall, wiping ...\Application Data\LibreOffice\, & then a reinstall & redoing the settings to see if that makes a difference.

I'll try it, but I'm not very optimistic about the outcome.
Comment 10 Alien 2012-07-26 13:53:31 UTC
I uninstalled LO, removed the remnants left behind in \Program Files (x86)\ and \Application Data\LibreOffice\, then reinstalled LO (v3.5.5.3).

Still the problem exists: set icon style to *anything* other than Automatic (Tango) and it crashes if I try to use 1 of the affected wizards.

As I'd previously discovered the location of the zip files with the icon images in, I copied them to another location, & had a look to see if any contained the icons I wanted, as I already knew of the function to change icons to imported images.

So far, I've managed to find & replace most of the icons I usually have visible in Writer, but the wizards still work without crashing, which leads me to believe that the problem is linked to whatever is changed by changing the
Tools -> Options -> LibreOffice -> View -> icon style
setting.
Comment 11 Julien Nabet 2012-12-12 21:26:04 UTC
Alien: could you give a try to a newer LO version (last one is 3.6.4) and tell us if it's ok?
A lot of bugs concerning Java7 have been resolved.
Comment 12 Julien Nabet 2013-01-19 14:15:37 UTC
No Feedback since months, so put it WFM

Alien: I know you've already made a lot of tests but as I said in my previous comment, a lot of Java related bugs have been fixed. If you reproduce the crash with last LO version (3.6.4), don't hesitate to reopen this tracker.

Also Xisco (put in cc) has converted some wizards from Java to Python.
Xisco: could you indicate which ones and in which version (LO 3.6 or from 4.0 only)?