Download it now!
Bug 52318 - LOCALHELP: Icons and text wrong and/or missing for new LibO File dialog
Summary: LOCALHELP: Icons and text wrong and/or missing for new LibO File dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.6.0.2 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-20 17:51 UTC by Rainer Bielefeld Retired
Modified: 2013-04-14 14:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Copy of affected Help page (26.41 KB, application/vnd.oasis.opendocument.text)
2012-07-20 17:51 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-07-20 17:51:48 UTC
Created attachment 64458 [details]
Copy of affected Help page

Help under "Opening Documents" (I only checked for WRITER) mostly is still for old dialog, for details please see attached Help copy. With Server Installation of  "LibreOffice 3.6.0.2 rc  English UI/ German Locale [Build-ID:  815c576] on German WIN7 Home Premium (64bit)
Comment 1 Rainer Bielefeld Retired 2012-07-29 13:41:33 UTC
Has been confirmed 2012-07-29 on <discuss@de.libreoffice.org> by Thomas
Hackert.

@David:
Please change Status to ASSIGNED and add yourself to "Assigned To" if you
accept this Bug!
Comment 2 Thomas Hackert 2012-07-29 14:42:36 UTC
Hello Rainer, *,
yes, I can confirm Rainer's observation, but want to add, that - instead of Rainer's "Server icon missing" at the end of the attached document - it should be in front of the header "Up One Leavel" with its own header and an adequate help text below ... ;) After I switched the LO GUI to English, clicking on the help button leads to http://help.libreoffice.org/swriter/SVT_HID_FILEDLG_AUTOCOMPLETEBOX?Language=en-US&System=UNIX&Version=3.6, where you only get the message
<quote>
There is currently no text in this page. You can search for this page title in other pages, or search the related logs.
</quote>
... :(
HTH
Thomas.
Comment 3 Paul Weiss 2013-01-13 19:49:32 UTC
I'm not clear what you think the problem is. The Up One Level and Create New Directory icons are correct in your attachment and in local help.
Comment 4 Rainer Bielefeld Retired 2013-01-14 05:54:56 UTC
@Paul Weiss 
May be my report text is a little misleading. The problem is that there Thewre is no such function "Up one level" in the new LibO Files dialog, and so this complete paragraph is nonsense.
Comment 5 Paul Weiss 2013-01-14 15:37:16 UTC
That function is showing up in LO dialogs and works correctly, 3.6.4.3, English, Windows 7.
Comment 6 Rainer Bielefeld Retired 2013-01-14 16:23:09 UTC
@Paul Weiss
You are right, my report mixes up an already fixed problem with still existing ones, I will correct that tomorrow
Comment 7 Andras Timar 2013-04-14 14:36:46 UTC
Wrong icons: I fixed this on the other day, icon theme was not (fully) respected in local help. 
Missing text: see the commit below.
Comment 8 Commit Notification 2013-04-14 14:42:11 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8958c6b2dfdb38a7ef0a9415ab0f302cf19171df

fdo#52318: update help of LibreOffice Open/Save as dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.