Download it now!
Bug 52342 - AutoFilter CRASH
Summary: AutoFilter CRASH
Status: RESOLVED DUPLICATE of bug 47275
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-21 15:34 UTC by Damien
Modified: 2012-09-14 09:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damien 2012-07-21 15:34:28 UTC
Problem description: Data Auto Filter Crashes the Spreadsheet App. I have never been able to use this feature without the application crashing. Have not had a chance to raise the issue before.

Steps to reproduce:
1. Open blank spreadsheet
2. Type a few values into some cells in the same column
3. Select Data|Filter|AutoFilter
4. Select a value to filter on
5. App Crashes

Current behaviour: Yes

Expected behaviour: It doesn't crash

Platform (if different from the browser):
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2
Comment 1 billhook 2012-07-21 21:09:31 UTC
I could not reproduce this on 3.5.5.3, Win XP Sp3.
Comment 2 Rainer Bielefeld Retired 2012-07-22 07:55:00 UTC
I every day use Autofilter hundreds of times with "LibreOffice  3.5.5.3.  German UI/Locale [Build-ID: 7122e39-92ed229-498d286-15e43b4-d70da21] on German WIN7 Home Premium (64bit).

Might be a DUP of Bug 47275

@Damien
Please attach  a sample document
Comment 3 Damien 2012-07-22 13:25:20 UTC
Thanks Rainer! Yes your were correct. Turning off the Universal Access resolved the issue.
Comment 4 Rainer Bielefeld Retired 2012-07-22 13:44:06 UTC
So let's mark this a DUP, what increases importance of a FIX there

*** This bug has been marked as a duplicate of bug 47275 ***
Comment 5 Damien 2012-07-22 20:22:12 UTC
Unfortunately, now that this works, My TextExpanded App won't run. TextExpander uses the features of the Universal Access feature. 

So my next question is, do we have a fix that allows the AutoFilter to work while Universal Access is enabled?
Comment 6 Rainer Bielefeld Retired 2012-07-22 20:35:08 UTC
@Damien:
Please follow bugfixing process in "Bug 47368 - Many crashes when accessibility enabled on MacOS X"
Comment 7 Roman Eisele 2012-09-14 09:27:36 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

I am currently doing a survey about all bugs which are related to Mac OS accessibility features. In the case of this bug, no action is necessary: it is correctly marked as a duplicate of bug 47275, which is really very similar, and when/if bug 47275 will get fixed, the present bug will be fixed, too.

So we can let the present bug stay marked as a duplicate of bug 47275, and don’t need to handle it separately.

(However, the “Steps to reproduce” in the current bug are much better than the description in bug 47275 -- thank you, Damien! --, and therefore we should use the “Steps to reproduce” given here also for the handling of bug 47275.)