Download it now!
Bug 52427 - UI of Database Report Builder mostly without translations
Summary: UI of Database Report Builder mostly without translations
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.6.0.2 rc
Hardware: Other All
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:3.7.0 target:3.6.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-07-24 06:27 UTC by Rainer Bielefeld Retired
Modified: 2012-07-28 15:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-07-24 06:27:23 UTC
I see that with Server Installation of  "LibreOffice 3.6.0.2 rc  German UI/Locale [Build-ID:  815c576] on German WIN7 Home Premium (64bit), samples with French ans Spanish showed that in all languages the same Icons (Properties, Left align on section, but: Izquierda) are with English Tooltip and Menu Items (Grid, Ruler, Shape Arrange, ...) in English

Was ok with 3.5.5, so Regression

New due to discussion on German Mailing list <discuss@de.libreoffice.org>

@András:
this seems to be a problem with common root for all Languages?
Comment 1 Jochen 2012-07-24 08:18:12 UTC
see also Bugreport 52399 (duplicate?)
Comment 2 David Tardon 2012-07-25 08:51:45 UTC
The extension contains untranslated registry files. (Sorry, this is my fault--is has been caused by gbuild conversion of reportbuilder module.)
Comment 3 Not Assigned 2012-07-25 09:01:44 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dda589ba60ff5ea104d85f0a09759c954498a5c9

fdo#52427 fix l10n of reportbuilder
Comment 4 Not Assigned 2012-07-25 09:41:44 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1ca38aa592fa8b5adebb8832681babbf95e1eff&g=libreoffice-3-6

fdo#52427 fix l10n of reportbuilder


It will be available in LibreOffice 3.6.1.
Comment 5 Not Assigned 2012-07-25 09:59:49 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1fec90a8f88379643414529e14b3626e682321a&g=libreoffice-3-6-0

fdo#52427 fix l10n of reportbuilder


It will be available already in LibreOffice 3.6.0.
Comment 6 Rainer Bielefeld Retired 2012-07-28 15:43:10 UTC
Fix Verified with Server Installation of  "LibreOffice 3.6.0.2 rc  German UI/Locale [Build-ID:  815c576] on German WIN7 Home Premium (64bit)
Comment 7 Rainer Bielefeld Retired 2012-07-28 15:46:03 UTC
Oops: verified with Server Installation of  "LibreOffice 3.6.0.4 rc  German
UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit)