Download it now!
Bug 52437 - xslx FILESAVE, FILEOPEN: comment display status is not saved; file become huge in size
Summary: xslx FILESAVE, FILEOPEN: comment display status is not saved; file become hug...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-24 10:30 UTC by Vincent Boudry
Modified: 2012-12-26 10:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Display following the opening (137.99 KB, image/png)
2012-07-24 10:30 UTC, Vincent Boudry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Boudry 2012-07-24 10:30:39 UTC
Created attachment 64602 [details]
Display following the opening

On a big xlsx file, (see attachement),
The normally hidden comments are all displayed.
The borders became very thick.

Beside the file size becomes huge:
380k for the ods version
9.2MB for the xlsx.

This might result from incremental corruption (file edited numerous time in LO and excell.).
Comment 1 Vincent Boudry 2012-07-24 11:38:50 UTC
The file con be found here: http://llr.in2p3.fr/~boudry/Public/HugeCorrupted.xlsx
Comment 2 Vincent Boudry 2012-07-24 11:47:09 UTC
Saving the file in .xls (97/2000/xp/2003) seem to fix many some deficiencies (size=1,8M [still!], border size)
Comment 3 Roman Eisele 2012-07-24 17:48:16 UTC
Hello Boudry,

thank you very much for your bug report! However, we have a little problem which prevents uns from confirming your report: If I try to access the file --

(In reply to comment #1)
> The file con be found here:
> http://llr.in2p3.fr/~boudry/Public/HugeCorrupted.xlsx

I just get a server error message: "You don't have permission to access /~boudry/Public/HugeCorrupted.xlsx on this server."

Now, how to get your file? Thank you for clarification!
Comment 4 Roman Eisele 2012-08-21 17:26:46 UTC
(In reply to comment #1)
> The file con be found here:
> http://llr.in2p3.fr/~boudry/Public/HugeCorrupted.xlsx

And now I get the message:
> The requested URL /~boudry/Public/HugeCorrupted.xlsx
> was not found on this server.

So, how to get the file now? Please answer, or we have to close this bug report without any progress ...
Comment 5 Vincent Boudry 2012-08-30 08:58:08 UTC
Bonjour,

I have changed the corrupted permissions.  It should be fine now.

Cheers,
Vincent.
Comment 6 Roman Eisele 2012-09-04 08:34:45 UTC
Thank you! Now the file is actually accessible ... I will take a look at it if I get some time.
Comment 7 Roman Eisele 2012-09-05 14:57:28 UTC
Well, it is not easy to “reproduce” this issue in the literal sense, because for this I would need to start with a correct file, maybe edit it in a specific way, save it as .xlsx file, and then see all the problems mentioned in the original report appear out of nowhere ;-) This is not possible, of course, in issues like this one, because the file is already infected by the mentioned problems.

But at least I can CONFIRM that Boudry’s .xlsx file, when opened with LibreOffice 3.5.6.2 or 3.6.1.2 on Mac OS X 10.6.8 (Intel),

1) shows all comments, which should normally be hidden (see the screenshot!);
2) the cell borders are extremely thick (4pt, like on the screenshot!), and it
   is reasonable to assume that this thickness is not a user setting, but was
   introduced by some bug;
3) the size of the .xlsx file is huge (9.2 MB), and this size is far bigger
   than what should be necessary to store the contents of the file, so the
   file size seems to indicate some kind of corruption.

That makes 3 separate issues, and it would be better to create a separate bug report for each of them. But I hope this is not necessary, because IIRC at least for some of these three issues there are already bug reports -- let us search for them later.
Comment 8 Roman Eisele 2012-09-05 15:19:12 UTC
At least we can try to bring some light into issue (3), the file size problem.


First I do some tests with LibreOffice 3.5.6.2 (German langpack installed, on Mac OS X 10.6.8 Intel):

a) If I "Save as" the .xlsx file directly as another .xlsx file, the new
   .xlsx file is still 9.2 MB in size.
b) If I save the file in .ods format, the resulting file is only 319 KB in size;
   if I save the .ods file back to .xlsx format, the file is again 9,2 MB
   in size.
c) If I save the file in .xls (traditional) format, the file becomes 62.5 MB (!)
   in size, a clear sign of corruption.

These observations, especially (b), confirm that issue (1) is due to some problem with FILESAVE in .xls/.xslx format, and that at least this issue is easily [REPRODUCIBLE].


But there are good news especially about this problem: if I repeat these tests with LibreOffice 3.6.1.2 (Build ID: e29a214) on the same machine, my results are different!

a) If I "Save as" the .xlsx file directly as another .xlsx file, the new
   .xlsx file is only 655 KB in size.
b) If I save the file in .ods format, the resulting file is only 319 KB in size;
   if I save the .ods file back to .xlsx format, the file is only 655 KB
   in size.
c) If I save the file in .xls (traditional) format, the file becomes 1.8 MB
   in size, which is big, but seems much more reasonable than before.

These results indicate that the bug with FILESAVE in .xls/.xslx format, while still reproducible with LibreOffice 3.5.6.2, is FIXED in LibO 3.6.1.2.

-> So we can “close” issue (3) from comment #7, and only need to deal with issues (1) and (2).


@ Boudry:
Could you please try yourself to download LibreOffice 3.6.1, open and "Save as" your .xlsx file, to confirm that you see the same fix of the file size problem, and to check if all data is still there (you will see that much more easily than me)?

If you don’t want to switch to LibreOffice 3.6 for now, I can send you the "fixed" .xlsx file and just ask you to check it if all data is still there.

Either of these options would be very helpful. Thank you very much!
Comment 9 Roman Eisele 2012-09-05 15:38:03 UTC
(In reply to comment #7)
> But at least I can CONFIRM that Boudry’s .xlsx file, when opened with
> LibreOffice 3.5.6.2 or 3.6.1.2 on Mac OS X 10.6.8 (Intel),
> 
> 1) shows all comments, which should normally be hidden (see the screenshot!);
> 2) the cell borders are extremely thick (4pt, like on the screenshot!), and it
>    is reasonable to assume that this thickness is not a user setting, but was
>    introduced by some bug;

This issue (2) is very probably the same as bug 52578 - “Incorrect Cell Border Width After FILESAVE/Reload Via .xlsx Format” (and the latter may be again a duplicate of bug 53287, but this does not matter here).

So issue (2) is reproducible, of course, but we don’t need to handle it, because there is already a special bug report for that issue.
Comment 10 Roman Eisele 2012-09-05 16:02:08 UTC
So, only issue (1) is still remaining:

(In reply to comment #7)
> But at least I can CONFIRM that Boudry’s .xlsx file, when opened with
> LibreOffice 3.5.6.2 or 3.6.1.2 on Mac OS X 10.6.8 (Intel),
> 
> 1) shows all comments, which should normally be hidden (see the screenshot!);

This issue is the same as bug 46278 - "FILESAVE: visibility settings of comments for cells are not saved in .xlsx format".

*

Summary: I can confirm all three issues (see comment #7) with LibreOffice 3.5.6.2, but
1) for issue (1), there is already the specialized bug 46278;
2) for issue (2), there is already the specialized bug 52578;
3) issue (3) is IMHO fixed in LibreOffice 3.6.1.2 (and better).

This allows us to close the present bug report; the status to use is difficult (issues 1 and 2 are RESOLVED/DUPLICATE, but of different bugs, and 3 is RESOLVED/WORKSFORME), but IMHO marking it as a RESOLVED/WORKSFORME is the best choice, because this is for issue (3), the only iusse which has not got (much) duplicates in our bug base.


@Vincent:
Hello Vincent,
please do not consider it as some kind of offence that I close your bug report. The opposite is true.

Multiple issues in one bug report, like in this one (3 issues), are difficult to handle. Therefore I need to split the report into different issues, and if I can sort out any of them as already fixed or as a duplicate of another bug, this makes bug handling easier, because it allows our developers to concentrate on the remaining bugs.

So please, verify if the file size issue is fixed for you, too, just as I asked for at the end of comment #8.

Thank you again!
Comment 11 Roman Eisele 2012-09-13 16:11:08 UTC
(If on Mac and 64 bit, “Platform” should be “x86-64 (AMD64)”: there never was a Mac with Itanium.)
Comment 12 Matthieu 2012-12-26 10:44:21 UTC
Hello,

For the issue 3, do you know if there is a patch or a commit which will correct the bug?

issue 3:
3) the size of the .xlsx file is huge (9.2 MB), and this size is far bigger
   than what should be necessary to store the contents of the file, so the
   file size seems to indicate some kind of corruption.