Bug Hunting Session
Bug 52471 - EDITING: Report-Designer eats all memory
Summary: EDITING: Report-Designer eats all memory
Status: CLOSED DUPLICATE of bug 33617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 54930 54933 44721
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 08:56 UTC by tbb
Modified: 2012-09-14 15:45 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tbb 2012-07-25 08:56:07 UTC
If I edit a report with some vertical lines (column separator) in a group section and select one vertical line one after another to change some properties, the report designer starts eating all my memory. I have to kill LO and all report editings are lost.
Comment 1 Jochen 2012-08-30 06:36:30 UTC
@Robert
Do you remember if other bugreports describe the same behvior. If yes: which bugreports?
Comment 2 Alex Thurgood 2012-08-30 09:54:05 UTC
(In reply to comment #1)
> @Robert
> Do you remember if other bugreports describe the same behvior. If yes: which
> bugreports?

Jochen,

Lines, as in fixed drawn lines, especially vertical ones, have been causing problems in reports for a while now, and even cause crashing in 3.6.0.4 and current master builds.

However, manipulating objects on the section canvas is also known to cause LO to use up all available memory and then eventually either have to be killed or kills itself.

So this report is a duplicate either of the lines problem, or the graphical object coordinates problem (which according to Thorsten is a ruler boundary code problem that has gone out of control).

Personally, I would stick it as a dup of the line drawing problem.

Alex
Comment 3 Jochen 2012-08-30 10:48:33 UTC
@Thorsten,

(In reply to comment #2)
> ... which according to Thorsten is a ruler boundary
> code problem that has gone out of control.

Please: have you time to look at this bugreport? What is your opinion: dup of another bugreport (which?)? Separate problem/bug? Do you need some further information?
Comment 4 Alex Thurgood 2012-08-30 12:23:22 UTC
(In reply to comment #3)
> @Thorsten,
> 
> (In reply to comment #2)
> > ... which according to Thorsten is a ruler boundary
> > code problem that has gone out of control.
> 
> Please: have you time to look at this bugreport? What is your opinion: dup of
> another bugreport (which?)? Separate problem/bug? Do you need some further
> information?

Sigh. Jochen, you could've looked these up for yourself :

https://bugs.freedesktop.org/show_bug.cgi?id=53872#c16

https://bugs.freedesktop.org/show_bug.cgi?id=33617

https://bugs.freedesktop.org/show_bug.cgi?id=44721

Alex
Comment 5 Alex Thurgood 2012-08-30 12:25:18 UTC
Taking a stab and marking as duplicate of 33617

Alex

*** This bug has been marked as a duplicate of bug 33617 ***