Bug Hunting Session
Bug 52518 - ACCESSIBILITY: "Font Name" and "Font Size" icons on VERTICAL formatting toolbar need to have "drop-down menus"
Summary: ACCESSIBILITY: "Font Name" and "Font Size" icons on VERTICAL formatting toolb...
Status: RESOLVED DUPLICATE of bug 55846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-26 01:33 UTC by minhsien0330
Modified: 2013-02-17 12:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
the "Font Name" icon on vertical formatting toolbar have the pop-out "Font list" (57.57 KB, image/png)
2012-07-26 01:33 UTC, minhsien0330
Details
Font size pop-out list (33.98 KB, image/png)
2012-07-26 01:34 UTC, minhsien0330
Details

Note You need to log in before you can comment on or make changes to this bug.
Description minhsien0330 2012-07-26 01:33:27 UTC
Created attachment 64693 [details]
the "Font Name" icon on vertical formatting toolbar have the pop-out "Font list"

Problem description: 
When I put the formatting toolbar to be VERTICAL, the "Font Name" and "Font Size" areas on formatting toolbar are chages to two icons, thus users can not chage fonts  and font size easily.
I think we need to have "drop-down menu" on "Font Name" and "Font Size" icons when the formatting toolbar was vertically arranged.


Steps to reproduce:
1. Drag the" formatting toolbar" to  vertical-left side in Libreoffice Writer
2. You can see  the "Font Name" and "Font Size" areas on formatting toolbar are chages to two icons.
3. Try to click  the "Font Name" and "Font Size" icon, you will find that is not convenient to use.

Current behavior:
Click  the "Font Name"  icon on vertical formatting toolbar, Writer show me the "Character" window.
Click the "Font Size" icon on vertical formatting toolbar,  Writer show me nothing, it had no function.

Expected behavior:
Click  the "Font Name"  icon on vertical formatting toolbar, Writer show me the pop-out "Font list". (please look the attachment "2.png")
Click the "Font Size" icon on vertical formatting toolbar,  Writer show me pop-out "Font sizes list". (please look the attachment "3.png")

Platform (if different from the browser): 
Browser: Mozilla/5.0 (X11; Linux i686; rv:10.0.5) Gecko/20100101 Firefox/10.0.5 Iceweasel/10.0.5
Comment 1 minhsien0330 2012-07-26 01:34:35 UTC
Created attachment 64694 [details]
Font size pop-out list
Comment 2 Jorendc 2013-02-17 11:39:50 UTC
Thanks for reporting!

I know they are working on the 'font size' button now, but I'm not sure also for the 'font name' list. Therefore I mark this bug as NEW and place the other enhancement request in the 'See Also' field.

Kind regards,
Joren
Comment 3 Jorendc 2013-02-17 12:15:58 UTC
I asked the developer that's currently working on Bug 55846 if he implement both (font name as well as font size). Therefore I mark this bug as duplicate of 55846.
The normal workflow is to mark a newer bug as duplicate of an older bug, but because there is all info etc I do it otherwise.

But you where the first that reported it ;-). Thank you!

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 55846 ***