Bug Hunting Session
Bug 52519 - Libreoffice crash when typing some Malayalam text using ibus
Summary: Libreoffice crash when typing some Malayalam text using ibus
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-26 02:13 UTC by balakrishanan
Modified: 2013-03-28 13:41 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (624.62 KB, application/x-compress)
2013-02-16 09:44 UTC, balakrishanan
Details
backtrace (26.38 KB, text/x-log)
2013-02-17 08:21 UTC, balakrishanan
Details
font attached (501.87 KB, application/zip)
2013-02-18 04:56 UTC, balakrishanan
Details
malayalm chracters (9.04 KB, application/pdf)
2013-02-21 04:09 UTC, balakrishanan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description balakrishanan 2012-07-26 02:13:49 UTC
When i try to type in Libreoffice writer in my language the key combination comes with "a&x" application crash and exits.
Comment 1 Joel Madero 2012-10-03 17:53:18 UTC
This is not enough information for us to properly triage the bug. 

1. What language? 

2. What distro?

3. What version of LibO

That's the minimum we need. Marking as NEEDINFO, please provide the information and reopen as UNCONFIRMED. I was unable to reproduce this using Telugu language + iBus + Bodhi Linux + LibO Version 3.6.2.1
Comment 2 balakrishanan 2012-10-14 03:09:52 UTC
I tryed Liberoffice 3.4,3.5,3.6.1

Ubuntu 11.10,12.04

Basic language English India

Problem in typing Indian language Malayalam.

Input method IBUS
Comment 3 Julien Nabet 2013-01-19 13:05:53 UTC
balakrishanan: could you try to retrieve a backtrace (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_.28on_Linux.29)? It could be very useful for debugging.
Comment 4 balakrishanan 2013-02-16 09:44:24 UTC
Created attachment 74928 [details]
backtrace

 Julien Nabet 

I am retrieve a backtrace of Libreoffice with this
Comment 5 Julien Nabet 2013-02-16 10:18:28 UTC
balakrishanan: you retrieved an strace, it may be useful but it's not a stacktrace/backtrace.

Could you follow this link? https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux
Comment 6 balakrishanan 2013-02-17 08:21:24 UTC
Created attachment 74965 [details]
backtrace

 Julien Nabet 
          

 pls find this new one
Comment 7 Julien Nabet 2013-02-17 09:13:31 UTC
balakrishanan: thank you for the bt!
Would it be possible you attach the font (ttf file I think) to the bugtracker so we can try to reproduce the problem?
Comment 8 balakrishanan 2013-02-18 04:56:29 UTC
Created attachment 75028 [details]
font attached


The font is default in ibus package .  i am attaching font here too 
For enable Malayalam package i add ibus-m17n  with synaptic.
or sudo apt-get install ibus-m17n
in ibus preference i  select's Malayalam 

i am using two Input Methods  mozhi and in-script both having same problem 
to reproduce problem  

if you using Mozhi you can type hOm with space 'O' must be capital.

in in-script you can type the word uax for this.  ax combinations having problem. 
 
Thank you
Comment 9 Julien Nabet 2013-02-18 21:25:15 UTC
balakrishanan: thank you for your feedback and for having attached the fonts.
About both input methods, I don't know how to do this.
I put a core dev on cc, he might help here.
I put the tracker to New since I don't have more question and you provided a backtrace.

Caolán: one for you? (a bt with symbols has been attached by the reporter)
Comment 10 Caolán McNamara 2013-02-19 12:21:29 UTC
#6  0xb594a042 in icu_48::LEGlyphStorage::reset() () from /usr/lib/libicule.so.48
#7  0xb593db8e in icu_48::LayoutEngine::reset() () from /usr/lib/libicule.so.48
#8  0xb593af2b in icu_48::OpenTypeLayoutEngine::reset() () from /usr/lib/libicule.so.48

hmm, a crash in icu itself apparently
Comment 11 Caolán McNamara 2013-02-19 16:16:35 UTC
Fixed icu-side fix as http://bugs.icu-project.org/trac/ticket/9948
Comment 12 Not Assigned 2013-02-19 16:26:01 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eea3634b2bd85e7f290e0504da1b8906c7d33ca4

Resolves: fdo#52519 crash on typing some Malayalam



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2013-02-19 16:41:58 UTC
So, I can fix our *internal* icu to not crash here, but the icu you are using is your system icu from Ubuntu, so that needs to be fixed for it not to crash for you. 

Perhaps Björn can help with that, and added some other distro folk who might want to patch their own icus too (I'll do Fedora)
Comment 14 Not Assigned 2013-02-19 17:14:54 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a8651cef191d77eeb19383d93789a51c34e641a0&h=libreoffice-4-0

Resolves: fdo#52519 crash on typing some Malayalam


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Not Assigned 2013-02-19 17:21:05 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=19b0f99d43d1bf43df3b650cdd698fb36de901e4&h=libreoffice-4-0-1

Resolves: fdo#52519 crash on typing some Malayalam


It will be available already in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Steven R. Loomis 2013-02-20 19:19:23 UTC
I don't seem to have the right keyboard for this, can someone attach the resultant document, or the exact Unicode chars? ICU has a short time to get this patch in (i.e. today).
Comment 17 balakrishanan 2013-02-21 04:09:40 UTC
Created attachment 75225 [details]
malayalm chracters

Steven R. Loomis

i am attached the file contain character's typed in meera font. 

 i am using qwert keyboard.
Comment 18 Caolán McNamara 2013-02-21 14:15:08 UTC
This is surprisingly difficult to reproduce with a static example. But here's a surefire way to crash for me with raw unicode input
0xd39, 0xd4b 0x0d02
(in gtk, ctrl+shift+u d39 space ctrl+shift+u d4b space ctrl+shift+u d02 space -> crash)
Comment 19 balakrishanan 2013-03-28 07:23:49 UTC
When i install  Libreoffice 4.01 problem solved.



Thank you all  

 Joel Madero 
Julien Nabet
Caolán McNamara
Comment 20 Petr Mladek 2013-03-28 08:54:41 UTC
Thanks for feedback. Let's mark the bug fix as verified.
Comment 21 balakrishanan 2013-03-28 13:41:28 UTC
 Petr Mladek 

Yes 

thank you for all efforts